Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem as I want to use a Samba NAS device as storage for my websites in IIS 7.0, they are all ASP.net websites. Surfing to them gives me a 401.2 error -> permissions problem

The bottomline is; I need to connect from a Win2008 Server's IIS to a samba share...

Error Summary

HTTP Error 401.2 - Unauthorized You are not authorized to view this page due to invalid authentication headers. Detailed Error Information Module IIS Web Core Notification AuthenticateRequest Handler StaticFile Error Code 0x80070005 Requested URL http://eva:80/Eccentric2009 Physical Path \192.168.0.40\Volume_1\DEVELOPMENT\WEBAPPS\Ecceff2009 Logon Method Not yet determined Logon User Not yet determined Failed Request Tracing Log Directory C:\inetpub\logs\FailedReqLogFiles

I only have a webinterface to configure my NAS device. This allows me to create (unix) users and groups. The users must have a password at creation. I guess it executes the 'adduser' command. It's all I can do. The NAS is not approachable via SSH or telnet.

Now, in IIS, when I try to access this device, it tries to access the NAS via COMPUTERNAME \IUSR and its password. The problem is the 'COMPUTERNAME\' (I guess!). In windows, I need to log in to this samba share with only username & password. -> Without computername ! In the IIS manager on the server I cannot find the option to log in with this credentials.

I read something about the option "authenticate as guest when computer information is available" but I'm not sure that's what I need.

FYI, the NAS is a conceptronic CH3NAS device, I'm running Win2008 R2.

Thanks a lot in advance !

share|improve this question
add comment

1 Answer

The problem your seeing is addressed on the NAS' FAQ page under "How to solve security problems with drive mappings, under Windows Vista?"

First, follow the instructions on the FAQ page, they should also apply to Win2k8:

The security policies which are being used by Windows Vista are not supported by the Samba software in the 'network storage device'. Therefore, to use file shares/folders of your 'network storage device', you need to change this the security policies of Windows Vista.

  1. Map a network drive to the NAS on your IIS server and connect as "Guest".
  2. Point your website's Local Path to that network drive.
  3. You'll have to grant the IUSR_ account access to the share on the Win2k8 box, but it won't matter that IUSR_ doesn't exist on the NAS, since the drive was mapped with "Guest".

You might have to change the security of "Guest" on the NAS.

share|improve this answer
    
Thanks for your reply, but I'm still stuck with this error: HTTP Error 403.14 - Forbidden The Web server is configured to not list the contents of this directory. The problem now is how to configure IIS, I choose for connect as 'IUSR_***" and when I try the connection test the authentication and the authorisation succeed... Thanks in advance! –  laurens Nov 9 '09 at 11:03
    
Do you get that error when attempting to browse to: eva:80/Eccentric2009 ? Since that URL doesn't include a specific file, IIS attempts to list the contents of the directory, which the IUSR_ account isn't permitted to do, or "Directory Browsing" isn't checked on "Virtual Directory" tab in IIS. Typically, websites are setup with a default page, such as default.htm. View the Documents tab of your site in IIS, make sure it's checked, and that a default page exists. –  Eric H Nov 9 '09 at 14:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.