Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed TFS 2008 and along with that came WSS (Sharepoint) 3.0. The server is located in a DMZ and has a hostname of "SVTFS". When the clients access it from the outside they use the fully qualified name "tfs.example.com".

Now, http://tfs.example.com/ is for the front page of the WSS server and it redirects to http://SVTFS/default.aspx. The SVTFS name is of course not accessible from outside the DMZ.

If I type http://tfs.example.com/default.aspx it loads just fine.

It's the same problem with project sites: http://tfs.example.com/sites/MyProject/ redirects to http://svtfs/sites/MyProject/default.aspx giving the user a DNS error.

Also, reports in the project pages tries to find the reporting server on http://svtfs/.

Anyone know how I can make WSS redirect to and use the fully qualified name instead of the local hostname?

share|improve this question

2 Answers 2

I had the same problem. You could do with making the question more generic, it took a bit of finding.

Walkthrough: Setting up Team Foundation Server with Secure Sockets Layer (SSL) and an ISAPI Filter provides step-by-step instructions and includes a section on alternate access mapping.

share|improve this answer
    
Yeah, perhaps it could be made more generic. I don't have any good ones now, maybe you have a suggestion so that I could edit it to be easier to find for others? –  henriksen Nov 16 '09 at 14:46
up vote 1 down vote accepted

Figured it out. I had to open SP Central Administration > Operations > Alternate Access Mappings and add the internet URL of http://tfs.example.com/ in addition to of http://svtfs/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.