Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently installed Ubuntu 9.10 (was on 9.04 before). I'm running a local development environment with Eclipse where my workspace is located at /home/jeremy/workspace. I installed the LAMP server using tasksel. I created a new virtual host pointing at a subdirectory in my workspace:

/home/jeremy/workspace/mysite.com/httpdocs

See below for the relevant part of my virtual host file which I started by copying the default host file. I've tried everything I can think of but no matter what I just get a 403 Forbidden error with this in my Apache log:

[client 127.0.0.1] (13)Permission denied: access to / denied

I set the group of the /home/jeremy/workspace/mysite.com directory and everything below to www-data. I also added my user (jeremy) to that group. I first tried chmod'ing that directory to 755. Didn't work. Then I went extreme and did 777 and that still didn't work! Has anybody got any ideas what is going on here? Is this a known issue for Apache on Ubuntu 9.10? I have made the appropriate entry in my hosts file so I know for sure that I'm accessing this locally.

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName mysite.com	

    DocumentRoot /home/jeremy/workspace/mysite.com/httpdocs

    <Directory />
    	Options FollowSymLinks
    	AllowOverride None
    </Directory>


    <Directory "/home/jeremy/workspace/mysite.com/httpdocs/">
    	Options Indexes FollowSymLinks MultiViews
    	AllowOverride All
    	Order allow,deny
    	allow from all
    </Directory>
</VirtualHost>
share|improve this question

1 Answer 1

up vote 0 down vote accepted

Check the permissions on every directory from /home/jeremy on up, one of them may not be allowing www-data access. I know on the 9.10 install I just did, home directories are created 700 by default, which would certainly restrict this.

share|improve this answer
    
Yes! That was it. I chmod'd /home/jeremy to 755 and it worked. Thank you! –  Jeremy Hicks Nov 6 '09 at 19:31
    
@Jeremy, be sure to accept Graeme's answer as correct if it solved your issue =) –  Kyle Smith Nov 6 '09 at 20:33
    
heh, thanks Kyle. –  Graeme Nov 6 '09 at 22:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.