Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
$/etc/init.d/bind9 restart
Stopping domain name service...: bind9rndc: connect failed: connection refused
Starting domain name service...: bind9.

(By the way, this is a continuation of the question here:

share|improve this question
There is insufficient information here to be able to take a reasonable stab at an answer, and you've been given guidance on what information to provide in your previous question, which should have been extended rather than asking another question. – womble Nov 6 '09 at 23:53
up vote 4 down vote accepted

You need to configure Bind and rndc if you want that rndc talk to Bind.

You should have something like that in your named.conf:

controls {
  inet allow { localhost; } keys { <key-name>; };


key "<key-name>" {
  algorithm hmac-md5;
  secret "<key-value>";

and something like that in your rndc.conf:

options {
  default-server  localhost;
  default-key     "<key-name>";


key "<key-name>" {
  algorithm hmac-md5;
  secret "<key-value>";

But you should read named.conf and rndc.conf manuals first ! :)

man named.conf
man rndc.conf
share|improve this answer
+1 for "But you should read named.conf and rndc.conf manuals first". :) – John Gardeniers Nov 7 '09 at 23:29

#953 is the rndc socket for controlling bind. the restart is giving you an error because it tried to connect to the socket and couldn't, probably because bind wasn't actually running.

After the startup script is finished running, does ps auxww show a 'named' process running? if so, and restart doesn't work, check your rndc key setup. If named isn't starting at all, look in the logs for why.

based on your other question you should do some reading before attempting to run dns. I recommend the cricket liu "DNS & Bind" O'Reilley book.

share|improve this answer
Yes, it is running. bind 16922 0.0 6.8 215020 22452 ? Ssl 09:49 0:00 /usr/sbin/named -u bind – Alex Nov 6 '09 at 22:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.