Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Virtual PC/VMWare machine that runs Windows Server 2003. This virtual machine uses an IPSec VPN client program to connect to a remote network. I configured the virtual machine to have 2 NICs:

  • NAT - to be used by the VPN Client to access the remote network
  • Host only - to be able to access the virtual machine from the host

The reason I have this setup is because I want to be able to access some remote network from the host machine. I could've installed the VPN client on the host machine, but the host runs Windows 7 and the client doesn't support it.

The problem: although the virtual machine is normally reachable (ping + http access), as soon as the VPN client is started, neither of the NIC addresses are reachable anymore.

I'm wondering if it is a routing problem that needs to be addressed? How do routing/VPN client connection affect the ability of the server to respond to client requests from the host?

share|improve this question
add comment

2 Answers

Many VPNs set themselves up as the only route for network traffic, and protect their position as the only route so you can not (at least, not easily) alter the routing while the connection is active. Most can be configured not to do this, of course, but that configuration is server side and the client will not allow you to override it without some considerable hacking.

What VPN client/server setup are you using? If it is something you have configured yourself then you are likely to be able to control the only gateway nature of the connection from the server side. If you are connecting to someone else's VPN service (for client support, for instance) then this is likely to be out of your hands.

share|improve this answer
    
Indeed, if it's a Cisco IPSec VPN typically the administrator sets this on the concentrator and does not let the client/user override the routes. –  troyengel Jan 10 '10 at 20:37
add comment

Do your pings traverse a gateway to reach your VM?

The setting that should fix this for you is in control panel -> network -> vpn connection -> tcp/ip settings -> Advanced

Look for 'use default gateway on remote network' and un-check it.

You'll probably get stuck in the middle on this - on one hand, you want some traffic to route via the VPNs default gateway. On the other hand, you want some traffic to route via your own network. If the tick-box doesn't solve the issue entirely for you, you'll need to see what IP ranges are needed in which networks, and start adding static routes as per this guide: http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sag_tcpip_pro_addstaticroute.mspx?mfr=true

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.