Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Etch on vmware server 1x on windows, I can only access the guest via ip and not hostname, I have no trouble with Debian Lenny, both installed 1 after each other with autp network config via local dhcp server, virtual network card is in bridged network mode, any ideas as to what may be the problem? im on a larger company lan which has either windows 2003 or bind server, not too sure which one is used as they both perform different functions...

share|improve this question
You don't mention at all what you're using for DNS...I'm thinking this might get moved to superuser. – Bart Silverstrim Nov 9 '09 at 13:02
i think it has something to do with dhcp lease and leaving a hostname with the lease record or something.. – Bren G. Nov 9 '09 at 16:01
i have tried setting "send host-name <hostname>" in the dhclient.conf but it didn't make any differrence? – Bren G. Nov 10 '09 at 12:20
up vote 0 down vote accepted

Installing SAMBA and disabling WINS in smb.conf automagically made it work...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.