Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i am using this line to configure MySQL 5.1

MySQLInstanceConfig.exe -i -q -lmysql_config.log ServerType=SERVER DatabaseType=MIXED ConnectionUsage=DSS Port=3306 AddBinToPath=yes ConnectionCount=10 SkipNetworking=no StrictMode=no RootPassword=password

it configures the server and the service is started fine, but the StrictMode is enabled even though i am disabling it in the configuration above...

if i look at my.ini i find

Set the SQL mode to strict sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

which i think is not supposed to be there...

am doing anything wrong? i am using the parameter wrong?

Vladimir,

share|improve this question

1 Answer 1

By using the my.ini mode of "STRICT_TRANS_TABLES", you are saying to use strict mode for transactional engines and, if possible, for nontransactional engines.

If you take that out, you should be ok.

share|improve this answer
    
Hi, i am not writing these values into the my.ini files, i don't understand how its being written when in the Instance Configuration i am setting the StrictMode to no... its like the configuration is ignoring the StrictMode Parameter... Please advise... Thanks for the reply Vladimir. –  Tuga Nov 10 '09 at 13:23
    
Vladimir, think of it as a conflict. In the command line you're telling it to not use strict. In the my.ini you are telling it to use strict. It's ignoring the strictmode parameter...because you're telling it to use strict mode by having STRICT_TRANS_TABLES. –  user6373 Nov 10 '09 at 13:47
    
Hi, i have not modified the my.ini files, i believe the my.ini file is created with the options you specify in the MySQLConfigInstance (or its supposed to). given a mchine that has never seen MySQL, i run the configuration as mentioned, but i still get the same results... maybe i should change the my.ini myself but that just sound wrong... –  Tuga Nov 12 '09 at 11:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.