Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to run yum update on my CentOS 5.2 box and keep getting this message:

Missing Dependency: libossp-uuid.so.15 is needed by package postgresql-contrib

I ran yum update postgresql separately and now it's 8.3.8. I also downloaded uuid-1.6.2 and built it from source, but I still get the same result.

yum update -d6 uuid gives me this at the end:

--> Running transaction check
---> Package uuid.i386 0:1.6.1-3.el5.kb set to be updated
Checking deps for uuid.i386 0-1.6.1-3.el5.kb - u
Checking deps for uuid.i386 0-1.5.1-4.rhel5 - None
postgresql-contrib requires: libossp-uuid.so.15
--> Processing Dependency: libossp-uuid.so.15 for package: postgresql-contrib
Needed Require is not a package name. Looking up: libossp-uuid.so.15
Potential Provider: uuid.i386 0:1.5.1-4.rhel5
Mode is u for provider of libossp-uuid.so.15: uuid.i386 0:1.5.1-4.rhel5
Mode for pkg providing libossp-uuid.so.15: u
Cannot find an update path for dep for: libossp-uuid.so.15
Searching pkgSack for dep: libossp-uuid.so.15
Potential match for libossp-uuid.so.15 from uuid - 1.5.1-4.rhel5.i386
Matched uuid - 1.5.1-4.rhel5.i386 to require for libossp-uuid.so.15
uuid - 1.5.1-4.rhel5.i386 is in providing packages but it is already installed, removing.
--> Finished Dependency Resolution
Dependency Process ending
Error: Missing Dependency: libossp-uuid.so.15 is needed by package postgresql-contrib

How can I resolve this situation? Thanks

share|improve this question

2 Answers 2

If going to postgresql 8.4 is acceptable I would recommend trying yum install postgresql84.

If you do not need the contrib RPM (it is not necessary by default), first remove it: rpm -e postgresql-contrib, then perform the update.

HTH, Neal

share|improve this answer

Snag and install this guy:

http://download.fedora.redhat.com/pub/epel/5/i386/uuid-1.5.1-3.el5.i386.rpm

rpm -Uvh uuid-1.5.1-3.el5.i386.rpm

This should update the contrib RPM.

share|improve this answer
    
Unfortunately... rpm -Uvh uuid-1.5.1-3.el5.i386.rpm warning: uuid-1.5.1-3.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 217521f6 Preparing... ########################################### [100%] package uuid-1.5.1-4.rhel5 (which is newer than uuid-1.5.1-3.el5) is already installed –  kdl Nov 10 '09 at 12:07
    
I tried rpm -e --nodeps uuid-1.5.1-4.rhel5 and then installing 1.5.1.-3 - still 'missing dependency'. –  kdl Nov 10 '09 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.