Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed everything EXACTLY in this tutorial for setting up DNS. I set up everything on a blank server.

However, starting BIND9 failed:

rndc: connect failed: 127.0.0.1#953: connection refused

I have Googled this, and it seems like there is not a good, solid answer.

share|improve this question
1  
Alex: Please follow the suggestions Florin, Yves, and Unknown gave, and come back here with the results. (Assuming you don't figure it out in the meantime.) –  Schof Nov 10 '09 at 0:32
add comment

5 Answers 5

up vote 7 down vote accepted

Check the logs, especially /var/log/daemon.log

There's got to be a clue in there somewhere.

share|improve this answer
add comment

Check whether you have SELinux or AppArmor, sometimes they mess with way file permissions are handled. /var/log/* should reflect that.

share|improve this answer
add comment

Review your named.conf file and your procedures. Check the named daemon logs. Most likely you didn't create an rndc key, or it has the wrong permissions.

Usually this command would help:

rndc-confgen -r /dev/urandom -a

share|improve this answer
add comment

The answer is that I had "forwarders" in my named.conf.options file...and this was unrecognized.

share|improve this answer
    
I found the answer, and I did go through Florin's method. –  Alex Nov 10 '09 at 0:33
add comment

Can you post your named.conf in here? and try to find a clue from syslog after start / restarting named service.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.