Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reason, I have a server that if ssh into another server...you don't need to enter the password.

How is this done? Can someone give me step by step instructions please?

share|improve this question

migrated from stackoverflow.com Nov 10 '09 at 3:44

This question came from our site for professional and enthusiast programmers.

4 Answers 4

up vote 6 down vote accepted

Check out this article. Essentially, I believe you're looking to generate and share keys between the local and remote machines in each ~/.ssh folder. The article outlines it better than I could. (And if that fails you, it's an easily Google-able subject).

share|improve this answer

ssh keys + an ssh-agent, you may also want to look into keychain. Read the following set of gentoo articles by Daniel Robbins for a good overview on openssh key management.

share|improve this answer

Most likely host-based authentication is enabled.

Look for the section on host-based authentication in the ssh manpage, and look for RhostsRSAAuthentication or HostbasedAuthentication in /etc/ssh/sshd_config

share|improve this answer
    
+1 In absence of any further details from OP and the OP having not taken any extra steps to establish an identity key pair this is the best possible reason for this behavior. –  Jeremy Bouse Nov 10 '09 at 14:34

SSH Keys. Try man ssh-keygen. Basically the machine you SSH into has a key (in ~/.ssh) that the machine to automatically ssh into generated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.