Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a shared hosted SQL Server 2005 at an ISP, that I can connect to from SQL Server 2005 Management Studio. However, I cannot connect from SQL Server 2008 Management Studio.

I log on with SQL Server authentication (username+password).

When I connect, I get the error:
The server principal "MyUserName" is not able to access the database [name of first database on server - 00_something - not mine] under the current security context.

How can I get around this, and just get straight to the one database I do have access to on this server? I tried setting the "Default database" for the connection to the name of my database, but it does not change anything.

I would really like to not have to install SQL Server 2005 Management studio to connect to this one database...

share|improve this question
    
Do you specify a default database when using SSMS 2005? –  K. Brian Kelley May 14 '09 at 18:14
    
K. Brian Kelley>> I tried both, it does not make a difference. –  Kjensen May 14 '09 at 21:26

2 Answers 2

up vote 8 down vote accepted

This sounds like the same issue you're running into...

The problem is that for a database that is offline or has been auto-closed, collation comes back as NULL, and SSMS assumes it's because you don't have permission.

The fix is to go to Object Explorer Details, right-click the column header list, uncheck Collation, and refresh the Databases node. You should see all of the databases on the server at this point.

More detail can be found in Microsoft Connect #354291 and Microsoft Connect #354322

share|improve this answer
    
Boom, that worked! Very strange error indeed. –  Kjensen May 14 '09 at 21:30

There is a connect item about this - the workaround is

Connect to another sql server and

  • highlight databases

  • Hit F7 to bring up object explorer

  • Right click the column names - ex "name", - you should see a drop down list of available columns

  • make sure collation is unchecked

  • Try connecting to the probelmatic server again

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.