Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have had my Outlook 2007 open additional mailboxes via the advanced account settings. After updating to Office SP2, the list of emails in the additional account still displays, but I get a message for each mailbox item:

 This item cannot be displayed in the Reading Pane. 
 Open the item to read its contents.

After double clicking the message, I get a small error box which displays just

 Cannot open this item. Unknown Error.

Also, if I try to re-add the mailbox in the Advanced tab of my account settings, I get an error message

The name cannot be resolved.  The connection to Microsoft Exchange is unavailable. 
Outlook must be online or connected to complete this action.

However, the status bar indicates Online with Microsoft Exchange, and I can both send and receive emails from my primary account. What could be going wrong?

share|improve this question

7 Answers 7

I've seen errors similar to this one, but it wasn't related to Outlook SP2. It was related to removing the last vestiges of the Exchange 2003 routing groups after we fully completed the migration to Exchange 2007. What was happening is that Outlook was storing the names of the mailboxes internally using an AD syntax to describe where to find the mailbox. Exchange 2007 uses a different location for that. This caused havoc in things like Delegates, replying to old emails, and the frequently-mailed-contacts list.

What was happening was that each user that was migrated from Exch2003 had an attribute called "LegacyExchangeDN" that pointed to the old AD location. Users created fresh in Exch2007 didn't have it, and didn't need it. After opening an SR with Microsoft to figure out what the heck, the fix was to add a new X500 address to each mailbox to the value of the old LegacyExchangeDN. This allowed cached Outlook entries (and there are a LOT of them) to find the mailbox.

That's a system-level fault, and it may not be your problem. But your symptoms seem close to what I've seen.

share|improve this answer

The error you recieved is usually a problem with locating the mailbox in the global address list. When you add the accounts into Outlook, try doing so with their UPN name, the name@domain.com, and using the pre 2000 login name.

share|improve this answer
    
I needed to confirm with the Exchange hosting company, but I was using the full UPN. –  Nick May 18 '09 at 15:19

The error on adding additional mailboxes was fixed by the hotfix http://support.microsoft.com/kb/968858/, however the "Unknown Error" when opening messages remains.

share|improve this answer

There is also the ugly and unpopular "recreate the account in a new profile" diagnostic step that sometimes makes Exchange problems go away.

share|improve this answer

i have also experienced this problem with a user, they have 2 mailboxes open in outlook 2007 sp2 and when they try to search on items in the inbox of the second mailbox they get "Outlook can not display this view. Unknown Error" they are able to search items in the deleted items and sent items only the inbox. I too get this error, i have uninstalled office and reinstalled it with only SP1 as the user said they used to be able to do it and SP2 is the only thing that has changed recently and it worked, i was able to add the users mailbox and search for items in the inbox. With SP2 i was able to search other users mailboxes with out the error. Not found a fix for it yet tho just thought i'd share my findings.

share|improve this answer

I've had a similar error, only that i had been adding a second, secondary mailbox on the already existing users mailbox. This after migrating from Exchange 2003 to 2010, on users machine, Windows 7 - Outlook 2007. Although going into Outlook's MS Exchange settings(connect to Exchange using HTTP) was good and well, didn't do anything for me. I performed a "dnsflush" command. I don't know if that would solve you issue but it worked for me.

Start -> Run -> cmd -> ipconfig /flushdns

share|improve this answer

set your LAN DNS IP to the Exchange Server, this solved it for me

share|improve this answer
2  
Can you add some detail to this. Hard to tell exactly what you are saying. –  Dave M Oct 16 '13 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.