Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to build documentation for PostgreSQL HEAD. It requires docbook 4.2, which I installed, but still the problem exist.

I described it in detail - including error messages, lists of packages, and configure options in mail to postgresql general mailing list.

Do you have any idea what to do to be able to build those docs?

share|improve this question
    
An Arch Linux Bounty Question?! OMG. –  Joseph Kern Nov 13 '09 at 16:22
    
@Joseph: I need those docs. –  user13185 Nov 14 '09 at 10:32
    
Have you tried the #archlinux irc channel? Do you have to use 4.2? I noticed there's a 4.5 in AUR ... –  Joseph Kern Nov 15 '09 at 15:15
    
@Joseph - yes I tried. Yes, I have to - these are PostgreSQL docs, and I have no influence over source format. –  user13185 Nov 16 '09 at 13:06

1 Answer 1

These 'no' strings in ./configure output are okay: the script just tests the system capabilities.

As far as I understand, there's an error in /etc/xml/catalog. It also depends on some files in /etc/xml, which in turn uses definitions from /usr/share/xml, you may be missing something. Try the archive I've prepared for you and overwrite your /etc/xml & /usr/share/xml with its contents (backup first!). I believe it should really help.

share|improve this answer
    
I know system checks capabilities, but it doesn't let me (later on) build docs. Which is not ok, as I need those docs. –  user13185 Nov 13 '09 at 5:23
    
Ehm, have you tried my suggestion? –  kolypto Nov 13 '09 at 12:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.