Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an MSP patch file for Microsoft Dynamics that runs fine on Windows XP, but fails to run on Windows 7. The file launches (with Microsoft Installer) but then fails and gives the error: A fatal error has occurred. The Microsoft Dynamics GP installation has ended prematurely. Click Finish to exit the installation.

I've tried turning off UAC, and running the file locally, but I still get the same error. It might be a bug, of course, but if anyone has run an MSP patch file successfully in Windows 7, that would be helpful to know. Or are there any other things I might try?

share|improve this question
up vote 0 down vote accepted

I found the answer. The trick was to first disable UAC, and then to install the .NET Framework 1.1 SP1.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.