Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to configure a Cisco 2600 series router to be DHCP server. To the ethernet port i want to connect a Cisco Catalyst 2900XL 24 ports switch, in this switch i want to connect a computer in port X2, the 2600 series router should be in port X1 and a internet uplink in port X24. On this uplink another DHCP server is running.

Is it possible to configure these devices so that the computer will recieve a IP address from the 2600 series router and not the DHCP on the internet uplink? The router should not broadcast DHCP addresse on the uplink either.

I do not want to make manual configurations on the computer, everything should be configured in the switch and router, if it is possible.

share|improve this question
    
Is the only reason you are putting the router into the equation is to act as the DHCP server? is some other service on the other end of the router? –  Zak Nov 10 '09 at 23:37
    
The router is also connected to another router over the serial interface. –  M. Smith Nov 10 '09 at 23:41
add comment

2 Answers

up vote 1 down vote accepted

It sounds like what you're trying to do should be fine. You can have either the switch or the router provide the DHCP service. You'll want to enable dhcp snooping on the uplink port (setting it to untrusted). That SHOULD drop any DHCPOFFER coming in from there.

ip dhcp snooping

ip dhcp snooping vlan number 110 (or whatever)

for each interface (not the uplink):

interface fe0/0

ip dhcp snooping trust

then you should basically be good.

share|improve this answer
    
On the 2600 i will configure a default route out the ethernet interface, should there be any special configuration on the switch to direct traffic to the internet uplink? –  M. Smith Nov 10 '09 at 23:48
    
nope. In general just set your default router properly. Other than that you have your usual arguments about setting duplex and speed vs autodetect..which I'm not going to get into here :) You should also investigate what sort of spanning tree settings you should use. –  user6373 Nov 11 '09 at 2:05
add comment

I don't believe you've provided enough information for us to help you.

A couple facts and some questions:

  1. The 2600 router won't pass DHCP requests by default. It needs to have "ip helper" enabled on the ethernet port pointing towards a DHCP server. An exception is if 2600 is setup for layer 2 bridging (you'll see bridge-group commands on the interface in question) --- then all layer 2 broadcasts (including DHCP requests) will get passed over that link. The reason for this is because routers block broadcasts by design. They connect multiple broadcast domains.

  2. The switch will pass all broadcasts, and all ARPs for unknown PCs, devices, etc. out all of the ports until the device in question replies.

  3. Spanning tree is likely a complete non-issue here.

  4. The "uplink ports" on switches are generally "special." Sometimes they have a pushbutton switch (I think maybe the 2900 does), which allows you to auto-cross the ports so you don't have to use a crossover cable. In your case, both the PC and the Router are "end devices" and connect with a straight cable. There's nothing special about port 24 here.

  5. You cannot have more than one DHCP server offering different network addresses in the same broadcast domain. If you want two servers serving up addresses from the same network range, you have to configure two separate address pools. (DHCP Handbook, second edition, by Droms and Lemon) There are also DHCP failover options for redundant servers.

  6. If you do end up configuring DHCP on your router, make sure that the addresses you pass out are in the same network as the ethernet port on the router. Example: Router IP is 192.168.1.1/24. You might want to pass out 192.168.1.2 -> 192.168.1.100. The default gateway for the PCs will be the routers IP address and has to be DIRECTLY reachable. If you change anything on the router, make sure that some routing protocol like OSPF is configured to announce this change of network range to the rest of the network.

Questions:

Is your router configured to route IP or bridge? Once again, look the presence of bridging commands like "bridge 1 protocol ieee" or "no ip-routing" and so on.

If your router is routing IP, then, is it configured for ip helper as described above?

If the router goes off to some corporate network someplace, please call IT immediately, tell them what you want to do, and they should be able to help you. Rearranging stuff like this can cause you lose connectivity, which would probably be a truck roll or at least multiple phone calls and troubleshooting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.