Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having some trouble trying to figure out how to Change a VLAN Assignement for an Interface on a Cisco 3750.

I want to change:

!
interface GigabitEthernet1/0/3
switchport access vlan 2
switchport mode access
spanning-tree portfast
!

Into:

!
interface GigabitEthernet1/0/3
 switchport access vlan 3
 switchport mode access
 spanning-tree portfast
!

However I haven't been able to do it successfully.

Any suggestions?

Thanks!

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted
conf t
int g1/0/3
switchport access vlan 3
do wr mem
share|improve this answer
    
thanks very helpful - I was missing the conf t –  mac Nov 10 '09 at 23:48
    
If you aren't used to it forgetting what mode you're in is a pretty easy mistake. Especially if you're trying to do a change during a 3am outage. –  sparks Nov 10 '09 at 23:49
add comment

What have you tried? It should go something like this:

switch# config t
switch(config)#  int gi1/0/3
switch(config-if)#switchport access vlan 3

Then ctrl-z and write mem

share|improve this answer
    
it should be 'swichtport access vlan 3' he wants to change from 2 to 3 –  Zypher Nov 10 '09 at 23:40
    
thanks very helpful –  mac Nov 10 '09 at 23:47
    
shouldn't there be a space in there as well? Or am I forgetting IOS quicker than I thought. –  sparks Nov 10 '09 at 23:48
    
@zypher,sparks: fixed, thanks. –  Chad Huneycutt Nov 11 '09 at 21:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.