Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of our client PC's recently got random crash issues with MS Word. I manually uninstalled Office 2003 locally on the client, ran "gpupdate /force /boot" and expected the client to reinstall Office after rebooting.

It didn't.

I've ran gpupdate a couple of times, but nothing seems to take effect. The only thing in eventlog of interest is the regular info that group policy software settings has been enabled.

Any ideas why it won't reinstall by it self? Does Group Policy contain some kind of magic log where it keeps track of wich clients it has installed?

Edit: The redeploy function in Group Policy is out of the question, as it would reinstall Office on all our computers on the next reboot.

Edit2: RSOP (both cmd and mmc) shows Office 2003 software package as deployed.

Edit3: Tried moving the computer to a different OU with slightly different software packages (but with the same Office 2003 policy). The other software installed at boot-up, but still no Office.

share|improve this question
    
I gave up and reinstalled the computer. Case closed. –  pauska Nov 12 '09 at 6:47

3 Answers 3

up vote 4 down vote accepted

This happens to me also, I manually uninstall a GPO package and there's no way I got it back, I noticed that there is a registry key that holds the GPO packages deployed.

  • Open regedit and browse HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\AppMgmt

  • Look in the subkeys for the product you want to redeploy and remove that key.

  • gpupdate /force

and the next time you reboot you will have the installation happening.

I haven't found a better way, it's a big problem for me, because users can uninstall the application "accidentally" and I haven't found a way around this.... amazing..

share|improve this answer
    
Thanks for this, I've updated your answer to be the solution. –  pauska Jun 22 '11 at 13:11

Do you have sufficient access to the AD where you could just move the computer to a new OU and apply a specific GPO to do the reinstall? That would avoid reinstalling all systems. It should be fairly quick as well.

BTW, did you run RSOP.MSC to see if there was anything there in the way of an explanation?

share|improve this answer
    
Hi. I'm the main administrator, so I have access to everything. The problem with creating a new OU is that I also have to create a new group policy object, with the customizations (etc). It's too much hassle and work IMHO. I ran RSOP.MSC and the commandline RSOP, and both shows the Office software package without any problems. –  pauska Nov 11 '09 at 15:46

Gave up and reinstalled the computer. Case closed.

Edit: See the accepted solution.

share|improve this answer
    
Glad you resolved this issue. Please be sure to mark your answer as "accepted" when you are able. –  jscott Jul 24 '12 at 13:01
    
@jscott lazy boy :) I've already accepted an answer, this one is left here for historical reasons.. –  pauska Jul 24 '12 at 17:35
    
Many apologies, the new /review doesn't display all the answers. –  jscott Jul 24 '12 at 17:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.