Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I found that when one of our machines reboot, I see audit errors in the event viewer saying that SQL Server Express cannot logon with NT Authority\System, there after my service application gives a similiar login error and does not start.

If I then start my service application manually (with services.msc), it starts perfectly. So the problem is only with rebooting.

So it looks like it is an issue with when the System account is available when SQL server service starts?

I could use an SQL server account in my applications SQL connection string but then would I still have the issue with SQL server express complaining (i.e. the audit error)? Alternatively, should I run SQL server express under another user account rather than local system?

JD.

share|improve this question

migrated from stackoverflow.com Nov 11 '09 at 14:24

This question came from our site for professional and enthusiast programmers.

    
This seems like a ServerFault question. –  Austin Salonen Nov 10 '09 at 15:51

3 Answers 3

up vote 2 down vote accepted

In Services.msc, double click your sql server service, and go to the recovery tab and change the default for 1st 2nd and 3rd failure to "ReStart the Service" and change the minutes to 2 or 3 minutes.

In reality, though, something else is happening on the underlying system. You should check the event logs for more errors.

Also http://ServerFault.com is a forum better suited to this, and so is http://Ask.SqlServerCentral.com

share|improve this answer
    
Thanks Raj and KevChadders. I switched to an SQL user and I got the same error on reboot but obviously this complaining that my service application and sql express could not log on with the SQL user account I created. I am now trying the restart option. –  user25741 Nov 10 '09 at 16:32
    
Just tried restart service option after 1 minute and unfortunately I get the same error on reboot. –  user25741 Nov 10 '09 at 16:36
    
We went for the delayed timer solution. Could not really find why the error was happening –  user25741 Nov 11 '09 at 13:35

I had a similar problem. I was able to resolve the problem by making the MSSQLSERVER service a dependency of my service by changing the registry:

\\HKLM\SYSTEM\CurrentControlSet\Services\Command Management System Host\your_service

Create a new REG_MULTI_SZ key called DependOnService and set its Data field to MSSQLSERVER.

I got the info on how to set a dependency from this MSDN entry.

Hope that helps :)

share|improve this answer

From experience I know SQL Express doesnt enable mix mode with SQL Server and Windows Authentication (On Installation)

Using SQL Management Studio, Right click on the Server and choose Properties. From there select the Security Tab and see how its set up.

This might not be the answer, but will hopefully point you in the right direction for solving it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.