Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, Here is the technical description.
My laptop's config:
Ip Adress:
Mysqlserver 5.0 on port : 3306
Operating system: Ubuntu jaunty (9.04)
3306 is open for both incoming and outgoing.

My friend's laptop config:
Ip Adress:
Mysqlserver 5.0 on port : 3306
Operating system: Windows XP pro
3306 is open for both incoming and outgoing.

Both are on a wireless LAN connected through a belkin router (

Both the MYSQL servers have been given the sufficient GRANT privileges. I am also able to connect from to's MYSQL instance but the vice versa is not happening. I am getting an (100061) error. Tried Telnetting on 3306; again happening from to but not the vice versa. Am I doing something wrong?
Kindly suggest.

share|improve this question
Exact error messages would be helpful; also, your claims that the grants and firewalls are all correct don't carry much weight, and they're the most likely causes of problems. Show that configuration, so we can check it for ourselves. – womble Nov 11 '09 at 19:20
Some Belkin WiFi Routers implement Wireless Isolation - can you ping the two systems from each other? If not I'd say this is possibly a factor. You say you tried Telnetting but didn't say what the result was, I assume it failed? Also the Belkin router model would help. – Helvick Nov 11 '09 at 19:42
@womble-Thanks for the response. Let me know exactly which outputs you need. I'll post them here. The GRANT command i executed on ( is as follows: GRANT SELECT ON . TO root@ IDENTIFIED BY 'root'; Since they are DEV systems user name and passwords are both root Then flush priviledges – Arnab Nov 11 '09 at 19:59
@Helvick-The Belkin router has the model no. F5D7230. Firmware version F5D7230-4_UK_8.01.07. Yes i can ping both the systems from each other. I am not satisfied with the isolation argument as i am able to connect from to Problem when trying to connect the other way. – Arnab Nov 11 '09 at 20:00

most likely Mysql on Jaunty does not listen for external addresses or is not configured to accept connections from external addresses.

Can you telnet 3306 port from your Jaunty laptop?

You should check /etc/mysql/my.cnf bind-address variable and make sure to comment it out as well as skip-networking.


Or bind address to all network interfaces

bind-address =
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.