Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am pretty new to system administration, and I am definitively new to serverfault, so apologies should my question not be following SF standards to the 100%.

This is my problem: I have a xubuntu machine with a number of accounts on it that I need to access remotely (in the same LAN but not in the same room). I would like my users to be able to use the GUI. More specifically I want to emulate the behaviour you experience when connecting via "terminal server client" to a windows machine.

If I got the documentation right, I can't use VNC as I do not need to "spec" an existing GUI session running on the remote machine: I want to open a new GUI session from the remote machine.

I considered a number of possibilities (XDMCP, FreeNX, the not-so-free NX from NoMachine...) but from ubuntu's documentation it looks like the best supported way of doing this is by using LSPT, as this is the architecture they already use in their thin client configuration (edubuntu).

Now, this is the question: although I could find in various places references to the fact you can use LSPT to do set up thick clients, I could not find any documentation on how to do this. Can anybody point me in the right direction?

Thank you in advance for you time! :)

share|improve this question

2 Answers 2

I suggest XDMCP, it's the longstanding supported way of doing this with X.

share|improve this answer
    
Thanks PJC for you answer, but correct if I am wrong: XDMCP sends usr/pwd unencripted, so - unless there's a way to tunnel that through SSH - I would rather pick some kind of more secure protocol. –  mac Nov 13 '09 at 12:33
    
there is a Secure Display Manager (SDM) in the debian repos; i believe it's main focus was using ssh for logins. i can't tell how well-supported it is at present though; it doesn't seem to be in active development. packages.debian.org/sid/sdm –  quack quixote Nov 13 '09 at 17:30
up vote 4 down vote accepted

After various tries, I finally managed to find a solution to my problems. Here's the how-to, it has been tested with:

  • Xubuntu 9.10 Karmic Koala
  • Freenx server v. 3.2.0-74-SVN OS (GPL, using backend: 3.3.0)
  • NX client from nomachine.com v. 3.4.0-5

SERVER SIDE:

Basically follow the instructions from the ubuntu community wiki. You will need to run:

sudo add-apt-repository ppa:freenx-team
sudo apt-get update
sudo apt-get install freenx
sudo /usr/lib/nx/nxsetup --install

I used the default configuration parameters for the install procedure (update: apparently launching the configuration procedure is superfluous if you are fine with the default parameters and encryption keys). Once installed, make sure your server is running by issuing

sudo /etc/init.d/freenx-server start

CLIENT SIDE:

  1. I chose to use the the free-as-in-beer client from nomachine. If you are following this how-to, you will need to download the client from their website.
  2. Once installed you will need to configure your session to work with XFCE.
  3. In General->Desktop select Unix/Custom and press the button "Settings"
  4. In the "Application" fieldset, select Run the following command and enter the command: startxfce4
  5. In the "Option" fieldset, select New virtual desktop

Now you will only have to enter your hostname, user and password and... voilà! you should be able to log in to your server!

Thanks to those who took the time to try to answer my question, anyhow! :)

share|improve this answer
    
As ubuntu is more and more deprecating call to upstart job, I would recommand to use service freenx-server start instead of /etc/init.d though it will also work. –  Kiwy Mar 12 at 8:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.