Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a domain name for a site that I am maintaining for a client. Being fairly inexperienced with DNS configuration, I'm having some trouble getting the domain name to point at the correct server consistently.

I currently have the following records set-up on 123-reg (the actual values here are made up, but closely reflect the real settings):

(TYPE A) "@"   :   "91.189.1.127"

(TYPE A) "example.co.uk"   :   "91.186.1.127"

(TYPE A) "www"   :   "91.189.1.127"

(CNAME)  "www.example.co.uk."   :   "example.co.uk."

This appears to work on most of the machines I have tested on - as long as they are not using OpenDNS. Looking at the CacheCheck tool on their site, OpenDNS appears to be picking up conflicting DNS results for each country in it's cache. One is correct, the other serves up some advertising page similar to this.

I ran a DNS traversal test on dnsstuff.com, and it reported 4 parent servers. The second 2 appear to be pointing to the correct machine, but the first 2 are pointing to what I assume is a parked domain name server:

dns1.name-services.com : 69.64.147.243

dns2.name-services.com : 69.64.147.243

ns.123-reg.co.uk : 91.189.1.127

ns2.123-reg.co.uk : 91.189.1.127

These 2 IP addresses match the 2 conflicting entries I am seeing on the OpenDNS CacheCheck service.

Right now I'm completely baffled. Is there anything obviously wrong with what I have set up? I haven't contacted OpenDNS yet, but wanted to get my facts straight first. What is my best plan of action?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

You should probably remove the first two name servers and only leave the 123-reg ones. Make sure to perform a cache refresh on the OpenDNS cachecheck.

share|improve this answer
    
After searching around the 123-Reg control panel, I eventually found the name servers. Removing the bad ones worked perfectly. –  seanhodges Nov 15 '09 at 20:19
add comment

OpenDNS turned evil (slightly tongue in cheek) when they started using wildcard records for all NXDOMAIN DNS responses. Baaaaaad. Don't use them for testing DNS queries is my advice.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.