Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After installing xen, them dom0 displays the following message:

***************************************************************
***************************************************************
** WARNING: Currently emulating unsupported memory accesses **
** in /lib/tls glibc libraries. The emulation is **
** slow. To ensure full performance you should **
** install a 'xen-friendly' (nosegneg) version of **
** the library, or disable tls support by executing **
** the following as root: **
** mv /lib/tls /lib/tls.disabled **
***************************************************************
***************************************************************

I don't exactly understand why I should move /lib/tls to /lib/tls.disabled. Can you explain why I should do this.

Does this apply to the domU as well?

I'm using Ubuntu Server 8.04 (3) LTS.

share|improve this question

1 Answer 1

The message means that Xen can't use it efficiently. I believe your versionof tls / xen are just outdated: have you considered upgrading?

'tls' supports concurrent multi-threading in applications (Thread-Local Storage specifically). Renaming it won't harm anything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.