Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Ubuntu 8.04 as a virtual machine using VMware Fusion 3.0 on Mac OS X 10.5.8. I want to be able to ssh into my VM from the Mac OS X host (so I can use MacFUSE and SSHFS to mount the VM's files on the Mac).

I had this working previously, but then I:

  • upgraded Fusion from 2.x to 3.0
  • rolled the VM back to a previous snapshot
  • upgraded the VMware Tools in the VM

I re-installed ssh in the VM using sudo apt-get install ssh.

I then tried ssh 172.16.193.129 from my Mac, and after some time it timed out. So I tried pinging the VM from my Mac, and 0 packets were received. (I can ping the Mac from the VM with no problem.)

Any advice on how to troubleshoot this?

Update: I tried switching from NAT to Bridged (as suggested by Stephen Thompson) and got strange "Time to live exceeded" messages when I tried to ping the VM. I realized that was due to the VPN I'm using. I disconnected from the VPN and can now ping the VPN and ssh into it, regardless of whether I use NAT or Bridged.

share|improve this question
    
All of your network configuration might be a good start. –  womble Nov 14 '09 at 6:32
1  
womble, I don't understand what you mean. –  Daryl Spitzer Nov 14 '09 at 14:41
add comment

3 Answers

up vote 8 down vote accepted

Try setting your network to bridged, so it picks up a network address from your lan, and you will be able to gain access to it.

share|improve this answer
add comment

Silly question but is 172.16.193.129 the current IP of the Ubuntu VM? For testing you should probably drop the firewall (iptables -F) if you configured it, as well.

share|improve this answer
    
Yes, I've of course double-checked that I have the right IP. (Using ifconfig. Because I'm using NAT in VMware Fusion to share the Mac's network connection, the IP number hasn't changed from when it was working before.) I didn't configure a firewall, but I ran iptables -F just in case. I still can't ping the VM. –  Daryl Spitzer Nov 14 '09 at 14:43
add comment

Steven Thompson's idea worked for me - for whatever reason adding an eth1 (bridged) seemed to fix eth0 (NAT) once I ran sudo dhclient (I checked, rebooting didn't fix it by itself, it was only fixed after I ran sudo dhclient )

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.