Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can someone please help me with this? I have a linux 2.6.9 server (I know it's outdated, but it has some special modules and so kernel cannot be updated/recompiled/etc), and I need to have a tun/tap interface on it for openvpn to work. Anyway I get an error Cannot open TUN/TAP dev. I tried running mknod command and it didn't work. Also it looks like there is no tun/tap driver loaded. Can someone please post a download link for a tun/tap driver for linux 2.6, I searched all over google and could not find one.

share|improve this question
add comment

2 Answers

I had a similar problem with an ubuntu 9.04 installation.

here is what i've done:

sudo su -
aptitude install udev
mkdir /dev/net
mknod /dev/net/tun c 10 200
chmod 0700 /dev/net/tun
modprobe tun
/etc/init.d/openvpn restart

If you're not using ubuntu or debian you cant just copy and paste this commands but maybe they point you into the right direction.

have a nice evening.

share|improve this answer
add comment

depending on your kernel you might need to

modprobe tun

if it turns out you do not have such module available - you'll need to upgrade / recompile your kernel [ it's good idea to do anyway 2.6.9 is quite ancient and probably vulnerable ]. the easiest way is by taking appropriate package from the distribution you are using.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.