Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I was doing some server updates and stupidly decided I should get the latest version of MySql. I had version 5.0 installed. Server is Windows Server 2003. I realize this is probably not the recommended upgrade route.

Here's what I've done so far:

  • Stopped the 5.0 service
  • Installed 5.1
  • Deleted 5.0 service
  • Configured 5.1 with same config as 5.0 with config wizard
  • Started 5.1 service
  • Copied data from MySQL\MySQL Server 5.0\data to AppData\MySQL\MySQL Server 5.1\data
  • Ran mysql_upgrade
  • Recreated users/privileges.

Two of my databases work and two don't. The two that do have files in their data folders with extensions .frm, .myd, .myi. The two that don't only have .frm files.

What do I need to do to get the non-working databases going?

Edit: I suppose I should clarify 'not working'. The non-working ones show up in the MySql Administrator and phpMyAdmin, but they have no tables listed.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I didn't copy the ibdata1 file. I stopped the service, copied that file from the old data directory, restarted and it's working. Huzzah

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.