Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have ~50 machines which connect via a 3G modem from Option (either the Globesurfer Icon, Icon 401 or Icon 7.2) to the network, for some reason from the telco they will be dropped (signal issue, tower, butterfly flapping it's wings - the telco is not much help here). After the drop, the machines fail to reconnect.

The error message that comes up is Cannot load phonebook. Error 1722 RPC is unavailable and checking the event log the following issue us listed there:
Event Type: Error
Event Source: MSDTC Client
Event Category: (10)
Event ID: 4427
Date: 2009/11/12
Time: 02:31:02 PM
User: N/A
Computer: TERMINAL
Description:
Failed to initialize the needed name objects. Error Specifics: d:\xpsp\com\com1x\dtc\dtc\msdtcprx\src\dtcinit.cpp:215, Pid: 3500
No Callstack, CmdLine: C:\WINDOWS\system32\dllhost.exe /Processid:{02D4B3F1-FD88-11D1-960D-00805FC79235}
Data:
0000: 05 40 00 80 .@.

The same issue will appear in the event log occur when trying to access the COM+ snap-in in the control panel.

The solution is to reinstall MSDTC by doing the following:
net stop msdtc
msdtc -uninstall
Delete the msdtc registry key
msdtc -resetlogs
msdtc -install
net start msdtc

This is on Windows XP Embedded SP 3.

What I am trying to find is the cause of the corruption of msdtc, but I am not sure where to start.


Updates

(17/11) The solution above, which reinstalls MSDTC, works in so that MSDTC is no longer corrupted and the machines can reconnect - however it does not correct the reconnection issue permanently. The machines can reconnect for a while (yet to determine how long or what changes) and then will fail - however without the MSDTC corruption this time.

(18/11) Testing the machines with a network connection, there issue never occurs. It would seem to indicate that the cause is something in the 3G modem.

(19/11) Tried upgrading the drivers to the latest versions with no change. Was also recommended to change the MTU to 1354, which has also not helped.

share|improve this question

2 Answers 2

That sounds like bad drivers to me. If you can't get newer drivers, try rolling back a version and see if the problem still remains. Sorry for not being anymore helpful than the obvious.

share|improve this answer
    
thanks for the idea - had the same idea yesterday and tried it and no luck with the latest drivers. –  Robert MacLean Nov 19 '09 at 7:13
up vote 0 down vote accepted

Something, unknown still, was wrong in the XPe image - likely from being resealed many times. A fresh XPe image from scratch resolved the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.