Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up SASL to a relayhost to send external email. I've read a hell of a lot and done everything I'm supposed to have done. However our provider won't accept me relaying emails with (we are not on their network, but they say this is ok as long as we auth with SASL).

Can anyone suggest how to get around these errors?

My mail log shows the following:

Nov 16 12:17:36 db3 postfix/smtpd[11576]: connect from 82-69-111-139.dsl.in-addr.zen.co.uk[82.69.111.139]
Nov 16 12:17:36 db3 postfix/smtpd[11576]: warning: SASL authentication failure: realm changed: authentication aborted
Nov 16 12:17:36 db3 postfix/smtpd[11576]: warning: 82-69-111-139.dsl.in-addr.zen.co.uk[82.69.111.139]: SASL DIGEST-MD5 authentication failed: authentication failure
Nov 16 12:17:37 db3 postfix/smtpd[11576]: NOQUEUE: reject_warning: RCPT from 82-69-111-139.dsl.in-addr.zen.co.uk[82.69.111.139]: 504 5.5.2 <danpc>: Helo command rejected: need fully-qualified hostname; from=<dan.smith@autovhc.co.uk> to=<d.smith@btopenworld.com> proto=ESMTP helo=<danpc>
Nov 16 12:17:37 db3 postfix/smtpd[11576]: C52C6258073: client=82-69-111-139.dsl.in-addr.zen.co.uk[82.69.111.139], sasl_method=LOGIN, sasl_username=dan.smith@autovhc.co.uk
Nov 16 12:17:37 db3 postfix/cleanup[11578]: C52C6258073: message-id=<001301ca66b6$d01fdab0$705f9010$@smith@autovhc.co.uk>
Nov 16 12:17:37 db3 postfix/qmgr[10775]: C52C6258073: from=<dan.smith@autovhc.co.uk>, size=6496, nrcpt=1 (queue active)
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) ESMTP::10024 /var/lib/amavis/tmp/amavis-20091111T171538-06836: <dan.smith@autovhc.co.uk> -> <d.smith@btopenworld.com> SIZE=6496 Received: from db3.wsautovhc.co.uk ([127.0.0.1]) by localhost (db3.wsautovhc.co.uk [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <d.smith@btopenworld.com>; Mon, 16 Nov 2009 12:17:37 +0000 (GMT)
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) Checking: vAhNgVoszXXC [82.69.111.139] <dan.smith@autovhc.co.uk> -> <d.smith@btopenworld.com>
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) cached 7a4790212196723b5d7702c38770fe2c from <dan.smith@autovhc.co.uk> (1,1)
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) p001 1 Content-Type: text/plain, size: 5609 B, name:
Nov 16 12:17:37 db3 postfix/smtpd[11581]: connect from localhost[127.0.0.1]
Nov 16 12:17:37 db3 postfix/smtpd[11581]: 380D425823E: client=localhost[127.0.0.1]
Nov 16 12:17:37 db3 postfix/cleanup[11578]: 380D425823E: message-id=<001301ca66b6$d01fdab0$705f9010$@smith@autovhc.co.uk>
Nov 16 12:17:37 db3 postfix/smtpd[11581]: disconnect from localhost[127.0.0.1]
Nov 16 12:17:37 db3 postfix/qmgr[10775]: 380D425823E: from=<dan.smith@autovhc.co.uk>, size=6983, nrcpt=1 (queue active)
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) FWD via SMTP: <dan.smith@autovhc.co.uk> -> <d.smith@btopenworld.com>,BODY=7BIT 250 2.6.0 Ok, id=06836-19, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 380D425823E
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) Passed CLEAN, [82.69.111.139] [82.69.111.139] <dan.smith@autovhc.co.uk> -> <d.smith@btopenworld.com>, Message-ID: <001301ca66b6$d01fdab0$705f9010$@smith@autovhc.co.uk>, mail_id: vAhNgVoszXXC, Hits: 0.468, size: 6496, queued_as: 380D425823E, 168 ms
Nov 16 12:17:37 db3 postfix/smtp[11579]: C52C6258073: to=<d.smith@btopenworld.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.63, delays=0.46/0/0/0.17, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 380D425823E)
Nov 16 12:17:37 db3 postfix/qmgr[10775]: C52C6258073: removed
Nov 16 12:17:37 db3 amavis[6836]: (06836-19) TIMING [total 171 ms] - SMTP greeting: 1 (1%)1, SMTP EHLO: 0 (0%)1, SMTP pre-MAIL: 0 (0%)1, SMTP pre-DATA-flush: 1 (1%)2, SMTP DATA: 38 (22%)24, check_init: 0 (0%)24, digest_hdr: 0 (0%)24, digest_body: 0 (0%)24, gen_mail_id: 0 (0%)25, mime_decode: 5 (3%)28, get-file-type1: 15 (9%)36, decompose_part: 1 (1%)37, parts_decode: 0 (0%)37, check_header: 1 (1%)38, spam-wb-list: 1 (1%)39, update_cache: 1 (0%)39, decide_mail_destiny: 0 (0%)39, fwd-connect: 13 (8%)47, fwd-mail-pip: 1 (1%)48, fwd-rcpt-pip: 0 (0%)48, fwd-data-chkpnt: 0 (0%)48, write-header: 1 (0%)48, fwd-data-contents: 0 (0%)48, fwd-end-chkpnt: 81 (48%)96, prepare-dsn: 0 (0%)96, main_log_entry: 5 (3%)99, update_snmp: 1 (1%)99, SMTP pre-response: 0 (0%)100, SMTP response: 0 (0%)100, unlink-1-files: 0 (0%)100, rundown: 0 (0%)100
Nov 16 12:17:37 db3 postfix/smtp[11582]: 380D425823E: to=<d.smith@btopenworld.com>, relay=mailhost.zen.co.uk[212.23.3.98]:25, delay=0.4, delays=0.08/0.01/0.22/0.08, dsn=5.0.0, status=bounced (host mailhost.zen.co.uk[212.23.3.98] said: 550-This is not an open relay. To send through this server you must either be 550 on a Zen Internet IP address or be authenticated over TLS. (in reply to MAIL FROM command))
Nov 16 12:17:37 db3 postfix/cleanup[11578]: A9DBC25823F: message-id=<20091116121737.A9DBC25823F@db3.wsautovhc.co.uk>
Nov 16 12:17:37 db3 postfix/bounce[11583]: 380D425823E: sender non-delivery notification: A9DBC25823F
Nov 16 12:17:37 db3 postfix/qmgr[10775]: A9DBC25823F: from=<>, size=9245, nrcpt=1 (queue active)
Nov 16 12:17:37 db3 postfix/qmgr[10775]: 380D425823E: removed
Nov 16 12:17:37 db3 postfix/virtual[11584]: A9DBC25823F: to=<dan.smith@autovhc.co.uk>, relay=virtual, delay=0.16, delays=0.08/0/0/0.08, dsn=2.0.0, status=sent (delivered to maildir)
Nov 16 12:17:37 db3 postfix/qmgr[10775]: A9DBC25823F: removed
Nov 16 12:17:39 db3 postfix/smtpd[11576]: disconnect from 82-69-111-139.dsl.in-addr.zen.co.uk[82.69.111.139]
share|improve this question
    
Can you post the relevent part of your config? –  LapTop006 Nov 16 '09 at 14:15
    
relayhost = mailhost.zen.co.uk smtp_sasl_auth_enabled = yes smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd smtp_sasl_type = cyrus smtp_sasl_security_options = –  Mr Shoubs Nov 16 '09 at 14:41
    
I changed the relayhost to another server (and the sasl_passwd file) but the first part of the relevent log details above appears to be the the same, I can't understand why. –  Mr Shoubs Nov 16 '09 at 14:43
    
for example I change relayhost to mail.btopenworld.com in main and sasl_passwd but the first line when trying to send is always connect from 82-69-111-139.dsl.in-addr.zen.co.uk[82.69.111.139] –  Mr Shoubs Nov 16 '09 at 14:51

1 Answer 1

up vote 1 down vote accepted

Be sure to check postconf -n

share|improve this answer
    
Even if you think its correct - a typo ment the setting wasn't picked up, postconf -n will make this obvious ;) –  Mr Shoubs Mar 4 '10 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.