Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Dell Poweredge 1750 that until yesterday was booted up, and seemed ok. It then froze, and on restarting, was presented with BSOD - Innaccessible Boot Device - 0x0000007B

Obviously, I've googled the issue, and thought it could be dead hardware.

However.. this is where it gets tricky - I've got an Acronis image of the server from a few days ago when it was perfectly ok. I've restored this onto fresh hardware, and booted it. This fresh hardware throws up exactly the same BSOD!

When I boot off the Windows CD, enter recovery console, it says that no installation of windows could be found etc...

I'm guessing it could be something to do with the RAID controllers suddenly going wrong.. I've updated the firmware to the latest batch.

Does anybody have any other ideas?

A fresh install of windows is pretty much out of the question as this is a business critical machine.

share|improve this question
1  
I'd look at the RAID controller, definitely. –  user3914 Nov 16 '09 at 13:48
    
what should I look for? No-one has changed anything that I know of and i've updated the firmware.... –  alex Nov 16 '09 at 13:59
    
can you boot a linux disk and test with testdisk? Otherwise do you have another server that has a similar RAID card from which you can test? Or what does the RAID card's diagnostics say? –  Bart Silverstrim Nov 16 '09 at 14:08
add comment

3 Answers

when you upgrade the raid controller firmware, you must make certain you have updated the storage driver first. Otherwise there's a chance that the older driver will not recognise the controller after the update, which always leads to a BSOD.

You can try to boot from a liveCD (RHEL or CentOS preferrably, since Dell have linux update packages for RHEL, which you can download to the liveCD and run), downgrade the firmware to the old version, and try to boot your OS again.

If that doesn't help, a LiveCD can be used to salvage the data from the system, before a proper reinstall.

share|improve this answer
add comment

Sounds like a dead RAID controller to me. The MS KB article here may help in troubleshooting (it says XP on the title bit it's also for Server 2003, which I'm assuming you have).

share|improve this answer
add comment

i finally fixed it- It appears the disk got too full... there was mere kb of space available, and for some reason, that wouldn't let it boot. I ran CHKDSK /R and it eventually let me boot into windows, deleting many GBs of unrequired data.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.