Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Mac OS X Leopard as my host OS and have VirtualBox 3.0.10 installed.

I'm having some issues getting bridged networking running with an Ubuntu 9.04 guest VM.

I had bridged networking running fine a few months ago, but haven't booted up the VM in a while. Now when I boot up I cannot connect via bridged networking, only via NAT.

How can I get a bridged networking connection working between OS X as the host and Ubuntu as the guest VM?

Is there something I need to do on the OS X side first?

share|improve this question
add comment

3 Answers 3

If you are on a laptop is your bridged connection connected to an WI-FI provided interface?

share|improve this answer
    
no, i'm not on a laptop but that really doesnt matter. I'm on a Mac Pro that has both wifi and ethernet. I'm connecting via the ethernet adapater, not the wifi adapter, but that really doesnt matter. I am getting the same results with both adapters –  cpjolicoeur Nov 26 '09 at 15:23
1  
VBox has limitations when operating over the WIFI connection. –  FlyingFish Jan 4 '10 at 18:00
    
I'm having the same trouble with an ethernet connection. Does somebody know if it is just impossible and a major bug or is there a workaround? –  Clutch Jan 25 '10 at 15:39
add comment

Try adding a new/different controller to the Ubuntu VM in VirtualBox. If it still won't work, try creating a new VM, using the disk from the current VM as the boot drive. Sometimes the VM description files become corrupted, and creating a new VM fixes the problem.

share|improve this answer
add comment

There are probably several things working against you:

First, upgrade your version. 3.1.2 is out and 3.1.4 is in beta (at the time of this posting).

Second, have you looked in the log files VirtualBox generates? It will likely give you (or those trying to help) clues as to what is happening. They usually live where the virtual machine XML configuration file lives.

Third, as suggested, remove the existing network adapter in your VM configuration and re-add it. Or even better, add a different network adapter type (Maybe Intel instead of PCNet or vice versa).

Fourth, try statically assigning an IP address in your guest as to minimize the host networking issues.

Fifth, make sure the various VirtualBox adapters in your HOST are enabled and configured right. I am not entirely certain what it looks like in OS X land, but under Windows VirtualBox adds a "VirtualBox Host-Only Network" that if you disable or generally muck with, it causes no end to weird problems. On that same line, it would be worth checking to make sure none of your private subnets are conflicting with each other either.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.