Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The file

/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_frequency

reads a value of 800 Mhz. The powertop tool also suggested that 800 Mhz w3as the minimum frequency being used.

I changed the above-mentioned file to 1.6 GHz and monitored powertop tool again. To my surprise, it still said that the minimum frequency was 800 MHz instead of 1.6 GHz.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Run the following command:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

Its output is probably one line for each core/cpu that you have saying ondemand. This means that when the CPU is not in use, it will go back to the lowest speed.

Btw, the files /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors will tell you the available governors and you can take a look at governors.txt to see the behavior of each of them.

You will have to first set the appropriate governor and then set the desired speed.

share|improve this answer
    
I have set it to Ondemand . I want the minimum frequency to be 1.6 Ghz instead of 800 Mhz , which I'm not able to –  kashyapa Nov 17 '09 at 3:51
    
In that case, the easiest way is to use 'userspace' and a daemon like cpuspeed(8), which has an option for what you want (-m). –  Gonzalo Nov 17 '09 at 14:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.