Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ok, I'm having the exact same problem as in this question http://serverfault.com/questions/59635/outbound-ftp-on-server-2008-r2-stalls but the accepted answer didn't help me much...

I followed the third step of this http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings/ guide in order to configure my firewall for FTP, and I am able to authenticate, however, the data channel doesn't seem to be passing through the firewall. If I disable the firewall, everything works fine. Hope someone can help me, as this is really starting to annoy me.

Best regards,
x3ro

share|improve this question
1  
did you try following the article blogs.msdn.com/vivekkum/archive/2008/09/10/… –  Vivek Kumbhar May 11 '10 at 14:59

1 Answer 1

You need to allow the ftp server through the firewall. The default entry in the firewall is incorrect. Assuming you already have the correct ports open, you also need to do the following:

  1. Search for 'firewall' in the start menu search
  2. Click on 'Allow a program through Windows Firewall'
  3. There is a default entry for 'FTP Server', however this is NOT the one you need. In fact, if you have a look at the windows service for the FTP server, it is invoked via svchost.exe. Click on the 'Allow another program...' button, and enter C:\Windows\System32\svchost.exe.
  4. Once you have added this entry, tick the checkbox for both Home/Work and Public profiles.

This will allow you to successfully use the FTP server with the firewall turned on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.