Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Quick question but Gooling has not revealed an answer. When I do iptables -L, it seems to lag on displaying items in where I have limited the source to internal ips

The whole listing takes about 30 seconds to display.

I just want to know: Does this affect the speed of my incoming connections or is this simply a side effect of having all these ranges within my iptables rules?


share|improve this question
up vote 32 down vote accepted

Include the -n option so it doesn't try to use DNS to resolve names for every ip address, network and port. Then it will be fast.

share|improve this answer
I generally like iptables -vnL --line-numbers for my listing command. Keep in mind by default you don't see all the tables, for instance, the nat table. To see that nat table: -t nat – Kyle Brandt Nov 17 '09 at 17:50
Thanks, that makes sense. :) – Bartek Nov 17 '09 at 17:52

I've personally seen this happen on a server that was configured for LDAP authentication, but could not reach the LDAP server (this was SLED 10). In my case, "netstat -a" and "iptables -L" were both exhibiting the same behavior you describe. An "strace" of the netstat showed it hanging on a connection to port 636 (LDAP-Secure). Turning off the LDAP (which, for me, was not needed on this platform) fixed the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.