Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a web server with apache 2.0 installed. It comes with Zend Server install pack. When I’m trying to debug my php files apache serves a blank page with 503 service unavailable. Of course slow server-side code is tying up Apache requests for far too long, but I need it to wait, until my debugging comes to end.

When I call to the page from a browser it launches ZendStudio debugging my PHP script (request redirects Zend Debugger module). I debug through my script and if I finish debugging in 120 seconds, I normally return to the browser. When it takes more than 120 seconds the browser displays '503 service unavailable' and I can't return to page output. I have even forced 'max_execution_time = 300' 'max_input_time = 600' in php.ini and 'TimeOut = 500' in httpd.conf. No matter whether it is Opera, IE or Firefox. I spent two days googling it, no right answer until now.

share|improve this question

I found some additional information on this for Zend Studio 6/7. Go into Preferences -> PHP -> Debug -> Installed Debuggers -> Zend Debug -> Configure. Specify the Client Host / IP to the IP of your computer. In my case, the problem was that it was configured to send Zend Server a list of IP addresses, which then caused Zend Server to lag as it attempted to communicate with each one of them.

share|improve this answer

You tried to set the TimeOut directive?: Apache documentation

share|improve this answer
'TimeOut = 500' in httpd.conf - if you read the question carefully, no matter – user25932 Nov 19 '09 at 18:49

You can find the Zend config files at C:\Program Files\Zend\ZendServer\etc or C:\Program Files (x86)\Zend\ZendServer\etc for 64-bit

share|improve this answer

You have to edit the file called ZendEnablerConf.xml. You'll find the 120 seconds timeout there.

share|improve this answer
After you have edited ZendEnablerConf.xml file and saved it please don't forget to restart your Apache server (Zend Server) and restart Zend Studio or Eclipse as well... – user104134 Dec 14 '11 at 16:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.