Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a WAMP install (Apache 2.2.3, PHP 5.2.8) with a working Zend Optimizer. As soon as I add the php.ini lines for Zend Debugger:

[Zend Debugger]

and restart apache, I get a blank page and the following entry in the apache error log.

[Zend Debugger] Cannot receive start command
[Zend Debugger] Cannot send message

Now the incredible thing is that I had it working this morning and now, after reinstalling WAMP there is no way I can get it work again. php.ini is exactly the same as it was before.

I would be extremely glad to get help, I'm trying to get a working server environment going for over a month, can you believe that? I tried XAMPP, Zend Server and now WAMP and I'm going crazy slowly but surely.

share|improve this question
up vote 0 down vote accepted

A workaround I just found is to use instead of localhost. Maybe it's just something with the hosts (hosts.ini) file. But that has been ok so far.

It seems that the Debugger doesn't get the new way Windows 7 is resolving localhost, when I add an entry to the hosts file, I can partly debug. Still, my errand has not come to and end since everything is unstable.

share|improve this answer

This worked for me on my machine to, also running on Windows 7. Running Apache 2.2 and PHP 5.2.12

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.