Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting an error when I try to install .NET 2.0 on my Server 2003 SP1;

Error 25007.Error occurred while initializing fusion.
Setup could not load fusion with LoadLibraryShim()

.NET-Framework 1.1 is already installed, is that the problem? I always thought you can just override any older installations of .NET

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I experienced this problem and I tried each of the following. I'll start with the least intrusive solutions. You can try installing after each one:

--

[EDIT] This problem happened after I got a Windows Update for Visual Studio SP1. I uninstalled Visual Studio and reinstalled .NET 2.0 framework and everything worked properly.

share|improve this answer
add comment

I experienced this issue when an installer for another application started installing Microsoft .NET Framework 4.0 (such application required it).

I solved closing such installer, installing Windows Imaging Component in my operating system language (it's a prerequisite for .NET 4), then installing Microsoft .NET Framework 4.0 (downloading it from Microsoft site) and finally launching again the installer above.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.