Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is probably more of a Debian question than a VMWare question, but I've installed Debian 5 (from debian-503-amd64-DVD-1) through VMWare Workstation and I'm having trouble with accessing anything through the network... I can ping anything on the LAN or the internet:

$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=128 time=1.42 ms

$ ping www.google.com
PING www.l.google.com (209.85.225.104) 56(84) bytes of data.
64 bytes from iy-in-f104.1e100.net (209.85.225.104): icmp_seq=1 ttl=128 time=83.0 ms

But I can't get anywhere via TCP (using wget, lynx, or telnet)... any of the 3 apps just hang when they try to connect...

$ wget http://www.google.com
--2009-11-18 09:57:57--  http://www.google.com/
Resolving www.google.com... 74.125.95.103, 74.125.95.99, 74.125.95.147, ...
Connecting to www.google.com|74.125.95.103|:80...

$ telnet 192.168.1.222 8000
Trying 192.168.1.222...

(Yes, I am listening on port 8000 on that IP and can get to it from another box).

What steps can I take to troubleshoot why this is happening?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
  1. Turn off all antivirus software and windows firewall.
  2. iptables -F
  3. Then wireshark(dump) packets going from virtual machine. That will probably show smth.
share|improve this answer
    
No antivirus running, turned off Windows Firewall (even though I was allowing VMWare through it). What does iptables -F do? Trying wireshark now, but I have no experience in using it. Anything else I can do? I ran tracert to google (somehow got there in 1 hop) and to another box on the LAN (somehow never got past the first hop). –  Langdon Nov 18 '09 at 17:49
    
That rule cleans firewall. What type of network connection does your virtual machine have? Bridged? Nat? –  TiFFolk Nov 18 '09 at 18:08
    
NAT, which I believe is VMWare's default. –  Langdon Nov 18 '09 at 18:42
    
Ugh, sorry to waste your time, it's working now, under 7.0 (I just upgraded). –  Langdon Nov 18 '09 at 18:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.