Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've recently installed a new server and configure Bacula to automatically label up to 10 volumes. Very soon I've got a message that intervention was needed and when looking at it one volume was totally used and the rest in Append mode but not being used.

I managed to get that original one into recycle mode, but the rest just remain in Append mode and backing up doesn't work.

Here's some console output.

My volumes

*list volumes
Pool: Default
+---------+-------------+-----------+---------+----------+----------+--------------+---------+------+-----------+-----------+---------------------+
| MediaId | VolumeName  | VolStatus | Enabled | VolBytes | VolFiles | VolRetention | Recycle | Slot | InChanger | MediaType | LastWritten         |
+---------+-------------+-----------+---------+----------+----------+--------------+---------+------+-----------+-----------+---------------------+
|       1 | mozart-0001 | Recycle   |       1 |        1 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 2009-11-12 23:10:02 |
|       2 | mozart-0002 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       3 | mozart-0003 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       4 | mozart-0004 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       5 | mozart-0005 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       6 | mozart-0006 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       7 | mozart-0007 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       8 | mozart-0008 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|       9 | mozart-0009 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
|      10 | mozart-0010 | Append    |       1 |        0 |        0 |    1,296,000 |       1 |    0 |         0 | File      | 0000-00-00 00:00:00 |
+---------+-------------+-----------+---------+----------+----------+--------------+---------+------+-----------+-----------+---------------------+
Pool: Scratch
No results to list.

Running a backup:

*run
A job name must be specified.
The defined Job resources are:
     1: Main
     2: Catalog
     3: RestoreFiles
Select Job resource (1-3): 1
Run Backup job
JobName:  Main
Level:    Incremental
Client:   mozart-fd
FileSet:  Full Set
Pool:     Default (From Job resource)
Storage:  chopin-sd (From Job resource)
When:     2009-11-18 15:12:45
Priority: 10
OK to run? (yes/mod/no): yes
Job queued. JobId=28
18-Nov 15:12 mozart-dir JobId 28: No prior Full backup Job record found.
18-Nov 15:12 mozart-dir JobId 28: No prior or suitable Full backup found in catalog. Doing FULL backup.
*

The failure:

18-Nov 15:49 chopin-sd JobId 27: Job Main.2009-11-18_14.49.47.28 waiting. Cannot find any appendable volumes.
Please use the "label"  command to create a new Volume for:
    Storage:      "FileStorage" (/var/bacula-backups)
    Pool:         Default
    Media type:   File
*

Any ideas what might be going on? How comes it doesn't find any appendable volume?

share|improve this question
1  
Can you include the Default Pool and chopin-sd configurations from bacula-dir.conf, and the relevant device configuration from bacula-sd.conf? –  sh-beta Dec 14 '09 at 23:28
    
I ended up nuking the database and rebuilding it. Without changing anything in the configuration and it worked. –  J. Pablo Fernández Dec 15 '09 at 3:36
    
It works when you nuke the database because it no longer knows anything about the media. This makes restoring require scanning all the media and any future jobs will just stomp all over the first thing they come across, ruining your retention periods. –  Jeff Ferland Dec 21 '11 at 0:30
add comment

2 Answers

The InChanger flag is set to zero. If this setup is using a tape library you shold be able to run "update slots" in bconsole to scan the library and update the InChanger and Slot informatoin.

share|improve this answer
    
Media type: File –  Jeff Ferland Dec 21 '11 at 0:27
add comment
up vote -4 down vote accepted

In that case I ended up nuking the database and rebuilding it, without changing anything in the configuration and it worked. I'm not sure what happened. Since then I've had the same issue several times and it was solved by restarting directors and storages.

share|improve this answer
5  
This is a horrible answer to accept, and doubly so because it's your own. "I blew away my database of backups" is not a fix. –  Jeff Ferland Dec 21 '11 at 0:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.