Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to use nomachine nx server and client. But somehow it doen't work. What happens is the following:

  1. Client starts up
  2. Client authenticates with Server
  3. The NoMachine window appears for 2-4 seconds
  4. The NoMachine window exists

Somehow a "closeEvent" is sent. Here's what I see in the log file:

[Thu Sep 24 11:20:37 2009]: Starting nxcomp with options: 'NX> 299 Switch connection to: NX mode: unencrypted options: nx/nx,options=/home/foo/.nx/S-adnws029-1022-7EEF1367361DB2A7F4D9F76B06F4B434/options:1022'.
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor: opened file: [/home/foo/.nx/S-adnws029-1022-7EEF1367361DB2A7F4D9F76B06F4B434/session]
[Thu Sep 24 11:20:38 2009]: LoginDialog::ShowConnectionStatus code=[246] str=[Initializing X protocol compression] error=[0]
[Thu Sep 24 11:20:38 2009]: ProgressDialog::printNxStatus: [Initializing X protocol compression]
[Thu Sep 24 11:20:38 2009]: LoginDialog::ShowConnectionStatus code=[247] str=[Established the display connection] error=[0]
[Thu Sep 24 11:20:38 2009]: ProgressDialog::printNxStatus: [Established the display connection]
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: LoginDialog: slotAgentTimer
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: QClipboard: Unknown SelectionClear event received.
[Thu Sep 24 11:20:38 2009]: LoginDialog: slotAgentTimer
[Thu Sep 24 11:20:38 2009]: LoginDialog: Agent found closing windows...
[Thu Sep 24 11:20:38 2009]: LoginDialog: setting automatic reconnection to true.
[Thu Sep 24 11:20:38 2009]: Settings::flush
[Thu Sep 24 11:20:38 2009]: Settings::flush
[Thu Sep 24 11:20:38 2009]: LoginDialog: closeEvent received!
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: NXFileMonitor::readData
[Thu Sep 24 11:20:38 2009]: LoginDialog::destructor called begin
[Thu Sep 24 11:20:38 2009]: LoginDialog: stopAllTimers
[Thu Sep 24 11:20:38 2009]: LoginDialog: stopProgressTimer
[Thu Sep 24 11:20:38 2009]: Utility::getPreferencesFile: 'nxclient' -> '/home/foo/.nx/config/nxclient.cfg'
[Thu Sep 24 11:20:38 2009]: Settings::flush
[Thu Sep 24 11:20:38 2009]: Called destructor for protocol class
[Thu Sep 24 11:20:38 2009]: LoginDialog::destructor called end

Anyone with a helpful idea?

share|improve this question

migrated from stackoverflow.com Nov 19 '09 at 7:18

This question came from our site for professional and enthusiast programmers.

add comment

4 Answers

I've struggled to get NX to work properly on my servers. Here are the steps I took to get my systems working; note that I'm using Fedora 10 and 11, you don't say what distro you are on.

  1. Make sure selinux is not blocking your remote logins - /var/log/secure or /var/log/messages should tell you if this is the case.
  2. Make sure you have the xfs font server installed, and that the xfs service is running. To use xfs you also need to make the following change to your /etc/nxserver/node.conf:

    AGENT_FONT_SERVER="unix/:7100" (7100 is the default port for xfs)

  3. Make sure you have the xorg-x11-fonts-misc package installed.

  4. If you still have problems after doing steps 1 to 3 and restarting your NX server, bump up the logging level by making the following node.conf changes:

    ENABLE_PERSISTENT_SESSION="all"

    NX_LOG_LEVEL=7

    NX_LOGFILE=/var/log/nxserver.log

Also make sure that /var/log/nxserver.log is owned by user nx and group nx.

If you restart nxserver again and tail the log while trying to start an NX session, you should get enough detail to tell you what is going on.

share|improve this answer
add comment

I had this problem in Ubuntu 10.10, and after turning on logging by editing /etc/nxserver/node.conf, I saw that error message in ~/.nx/XXX/session described a python-dbus error, wherein /lib/dbus-1.0/dbus-daemon-launch-helper failed to start. So my one line solution was to apply:

sudo chmod 4777 /lib/dbus-1.0/dbus-daemon-launch-helper

which fixed the problem.

share|improve this answer
    
Ouch! You just made a file world-writable, so every user can take over part of the system… –  mirabilos Dec 24 '13 at 10:25
add comment

In order to make NX server work on my RHES 6.3 environment i had to change the following lines on the default /usr/NX/etc/node.cfg file

CUPSBinPath = ""
CUPSSbinPath = ""
EnableCUPSSupport ="0"
MountShareProtocol = "both" ## not sure if this is relevant

Also comment out the CommandStartGnome line out.

share|improve this answer
add comment

A colleague of mine faced this issue recently and I tried deleting all nx related files but that did not help. The only thing that worked was deleting his home directory. But the issue re-appeared soon again.

The reason turned out to be that he had some script running in his .bashrc which was preventing his NX profile from loading. He could however connect to putty/WinSCP without any issues.

Commenting that script line finally helped.

Thanks, MK

share|improve this answer
1  
Without knowing exactly what it was, this isn't really useful. –  Michael Hampton Sep 4 '13 at 3:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.