Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to open an application from my work's citrix presentation server on my macbook. I just downloaded the latest citrix client for mac from their website but when I go to launch an app it tries to open the app in VMware. If I right-click on the app and save target as, I get a launch.ica file which if I try to open in Citrix Dazzle it does not know how to open this file type.

share|improve this question

migrated from superuser.com Nov 19 '09 at 8:02

This question came from our site for computer enthusiasts and power users.

    
Is it an app or a document you are trying to open on the Citrix server ? I'm asking as it looks like the Citrix Mac client can have file type associations setup which might be triggering opening of VMware - which I'm assuming you mean VMware Fusion right? –  Sim Nov 18 '09 at 2:15
    
I logon to my work's citrix presentation server which is a web address. citrix.domain.com I then put my credentials into a from and login. I then am presented with a group of application icons. Selecting any of them starts 'launch.ica' which tries to open in VMware Fusion. If I were to right click an application icon and 'Save As' the file. Then try to open it with Citix Dazzle it does not open. Does anyone use citrix on a mac? is the web plugin or citrix dazzle not what I want? It doesn't look like there is anything else. –  CT Nov 18 '09 at 4:05
    
Do you have any Citrix Software installed in your VMware Fusion instance? –  Sim Nov 18 '09 at 6:29
    
Yes. I'd rather keep it but I will uninstall it to see what happens. –  CT Nov 18 '09 at 21:56

6 Answers 6

I was able to fix the same problem by changing the settings on the VMWare virtual machine, so that "windows applications" (i.e. Citrix apps, or so the system thinks) are not automatically opened with VMWare Fusion. I already had the Citrix plug-in downloaded, but the problem wasn't solved until I changed the settings in VMWare Fusion.

share|improve this answer

You need the Citrix ICA Client (http://www.macupdate.com/info.php/id/9610/citrix-ica-client).

Once you have installed it and associated .ica files with this app you should have no problems, although I would recommend using FireFox to login to your works' presentation server as I've have had issues with Safari.

share|improve this answer

I have no idea what Citrix is, but generally speaking, you select your file, do a Get Info on it and choose the application you would like to have open it from the little menu in the window.

share|improve this answer
    
Thank you but that is not my problem, I need to know what to do with a citrix .ica file. The only Mac citrix client is located here: citrix.com/English/ss/downloads/…. I have tried this. –  CT Nov 18 '09 at 0:51
    
That's a plugin, so you're going to need to use whatever application you installed it for to do your opening. –  NSD Nov 18 '09 at 1:20

This is caused by a VMWare Helper Application

1) you need to unregister it from VMWare

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -v -u ~/Documents/Virtual\ Machines/Windows.vmwarevm/Applications/Citrix\ Remote\ Application\ Runtime\ —\ Window.app/

2) Optionally delete the App to prevent it re-registering at the next login

3) Reinstall the Citrix Online Web Plugin

share|improve this answer

The is repaired quickly by reinstalling the 10.00.603 ICA client found in this location: http://www.macupdate.com/info.php/id/9610/citrix-ica-client as well as possibly on the Citrix web site.

My problem started when trying to grab the 11.x client, and all hell broke loose. I simply reinstalled the 10.X client over the top of the fouled 11.x and all associations are fine and works as expected.

This is not the final answer for those who need to run the latest ICA client plus VMs on Fusion, but it will get you working again.

share|improve this answer

My configuration: Citrix Online Plug-in 11.2, VMware Fusion 3.1.2, OS X 10.6.6 I tried to unregister/move the Citrix*.app from the VMware Fusion Applications folder, reinstalled Citrix plugin 11 again and again - no success. But it worked fine with doing the following:

  • download ica file via "save link as" function of the browser
  • select ica file in finder and press cmd+i
  • select Citrix Online Web Plug-in as open with
  • press change all
  • restart browser and try again

Just changeing the association of one ica file seems not to work, because the VMware Application helper stuff, or the Citrix connnection start mechanism itself, tries to start another ica file. That's my assumption.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.