Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install a PCI network card in a SunBlade 150 running Solaris 9. I have tried a number of different cards (D-Link, Netgear, Intel) and none of them "just work". Using prtdiag I can see the onboard interface which I do have working:

pci     33    +s/system-board  pci108e,1101 (network)        SUNW,pci-eri
              okay        /pci@1f,0/network@c,1

However, any PCI NIC that I plug into the motherboar shows up like this:

pci     33    +tem-board/PCI1  ethernet
              okay        /pci@1f,0/pci/ethernet

The word "ethernet" is a good sign, but there is no PCI ID listed, nor do I have the comforting "(network)" text.

I aleady tried ifconfig -a plumb as well as looking through kstat. What do I need to do to get one of these cards working? Do I need some special, proprietary Sun card? Appreciate any advice...

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I solved this by doing the following:

  1. Found a network card that was compatible with one of the Free NIC drivers for Solaris. In my case, I had an Intel card that was compatible with the "em driver for intel gigabit ethernet controller 8254x".
  2. Downloaded the source tarball and following the very explicit directions I found in README.txt.
  3. Unfortunately my system had no compiler, so I had to install gcc from sunfreeware. As per the gcc instructions, I also installed libiconv.
  4. Once I had the ability to compile, the README.txt told me nearly exactly how to do everything else.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.