Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is somewhat related to my previous question,

Having got the font install issue sorted out under XP just fine, recently we've got a Windows 7 workstation and I've created a special GPO for it. Initially it was UAC that was demanding administrative access to C:\windows\fonts despite the fact the policy dictates that directory is writable (as is the relevant registry entries, on XP anyway). The issue now though is that when I try to copy a font or hit install it claims that the font "does not appear to be a valid font". This happens with every type of font as well.

Is there some new and special consideration when allowing these changes on Windows 7?

Any input would be appreciated.

Many thanks, Doug

share|improve this question
up vote 2 down vote accepted

So I figured it out.

Having looked at the Resultant Set Of Policy and seeing nothing untoward there, I checked C:\windows\security\logs\winlogon.txt

The Windows 7 client GPO is a copy of the standard XP one that I created, and therefore had entries in it to allow domain users to edit the content of C:\windows\fonts.

However, Windows 7 shows this in winlogon.txt:

----Configure File Security...

Configure c:\windows\fonts.

Warning 5: Access is denied.

Error setting security on c:\windows\fonts.

I checked the GPO and removed the settings for this directory and re-added it, which upon a GPO update and restart gave me this:

----Configure File Security...

Configure c:\windows\fonts.

Configure c:\windows\system32\fntcache.dat.

File Security configuration was completed successfully.

I tried adding a font and voila! Worked as intended.

Hope this helps anyone else who may come across the same issue. No idea why re-adding the same security setting made it work but it did.

share|improve this answer

Well I can only suggest you have the UAC turned off because I have taken ownership and set the Windows 7 font directory and registry key permissions to allow users change access but the UAC keeps prompting for administrator credentials.

share|improve this answer
Yeah, I have UAC turned off, you are correct. – djk Mar 18 '10 at 10:12

This error occurs because the file attribute System is checked. Checked directorys at System cannot have their permissions changed. In my case I try these following command:

attrib -r -s %systemroot%\fonts

To correct these error below:

Warning 5: Access is denied.

Error setting security on c:\windows\fonts
share|improve this answer

Login with Admin account first

  1. Go to Run Command
  2. Type "regedit" click Enter
  3. Now you can see " HKEY_LOCAL_MACHINE" click and explore it
  4. next go to "SOFTWARE" then "MICROSOFT" after then "WINDOWS NT"
  5. Now you can see "Current Version" and go to "Fonts"
  6. Now you right Click on fonts
  7. go to change permissions
  8. make your local user permission for allow access..
share|improve this answer
How does this create a GPO to give desired result? – Dave M Dec 9 '15 at 15:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.