Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Sending mail via smtp.gmail.com is failing on my server. I looked on some forums and people were saying to make sure you can telnet to the smtp address first.

When I telnet from my server i input this and get this error:

[root@localhost ~]# telnet smtp.gmail.com 465
telnet: smtp.gmail.com: Temporary failure in name resolution
smtp.gmail.com: Host name lookup failure

From my OS X desktop I do the same and get this:

    Macintosh-3:~ joe$ telnet smtp.gmail.com 465
Trying 74.125.127.109...
Connected to gmail-smtp-msa.l.google.com.

I'm running a fedora core 9 server with a firestarter firewall. I have turned off the firewall and the same error persists. I'm also using port forwarding from my router to this server. I have allowed forwarding for port 465 on my router as well.

Can someone please help.

Thanks, Joe

share|improve this question
    
It looks like your server isn't able to resolve the name. What happens when you do a nslookup smtp.gmail.com on the server? –  Sim Nov 20 '09 at 21:23
    
Are the desktop and the server using the same DNS server? –  Sim Nov 20 '09 at 21:24
    
on the desktop i can nslookup fine. on the server i get the error: connection timed out; no servers could be reached –  petey Nov 20 '09 at 21:29
    
Can the server lookup other addresses? –  Sim Nov 20 '09 at 21:31
4  
Compare your /etc/resolv.conf with the DNS servers you're using in the Mac. Perhaps they are different? You can also try "dig +trace smtp.gmail.com" to get more info from DNS. –  Suppressingfire Nov 20 '09 at 21:51

2 Answers 2

For some reason, possibly the firewall on the server or router, the server can't resolve names. Check again that the firewall is turned off on the server and that when you setup the port forwarding on the router you didn't block DNS - udp port 53 normally, tcp port 53 for zone transfers and sometimes lookups.

share|improve this answer
    
Also have you setup forwarding on the router to send and receive mail or just send? I thought port forwarding was only for incoming traffic. –  Sim Nov 20 '09 at 21:40
    
As Suppressing fire says above you need to check to see that the server and the Mac are using the same DNS server. –  Sim Nov 20 '09 at 21:53

You could also address this issue by putting the IP address for smtp.gmail.com in your hosts file.

Another thing you could do is try telnet 74.125.127.109 465 to confirm that DNS name resolution is your only problem.

You could also telnet 74.125.127.109 25 to see if you can connect to the unencrypted port.

share|improve this answer
2  
Updating you host file with someone else's IP addresses probably isn't a good idea most of the time. This might have a value as test to diagnose an issue, but it isn't something I think anyone should leave set. Google has many servers. They may choose to disable the one you picked at any time. –  Zoredache Nov 20 '09 at 23:39
    
Telneting to 74.125.127.109 on ports 465 and 25 are a good idea thought to try and isolate the name resolution from connectivity. –  Sim Nov 21 '09 at 0:27
    
Using entries for /etc/hosts is especially bad for email. –  benc Jan 23 '10 at 19:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.