Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a fedora 12 system, and have installed tomcat6 via yum.

I can start tomcat by issuing: tomcat6 start

I can see this is OK by the catalina.out log file as follows

Nov 20, 2009 11:05:08 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
Nov 20, 2009 11:05:08 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8888
Nov 20, 2009 11:05:08 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 287 ms
Nov 20, 2009 11:05:08 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Nov 20, 2009 11:05:08 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Nov 20, 2009 11:05:08 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8888
Nov 20, 2009 11:05:08 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Nov 20, 2009 11:05:08 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/14  config=null
Nov 20, 2009 11:05:08 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 91 ms

I have changed the port for tomcat to 8888 as 8080 is in use elsewhere, I have changed this in server.xml as follows

 <Connector port="8888"
            protocol="HTTP/1.1" 
            connectionTimeout="20000" 
            redirectPort="8443" />

I can't get anything on http://localhost:8888 in any browser, I'm thinking that the firewall could have been blocking tomcat. I've disabled the firewall temporarily in system-config-firewall and restarted tomcat, but that doesn't seem to change anything

What else could be stopping access to tomcat? There is nothing in /var/log/messages regarding tomcat other than the yum install logging

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I wouldn't have thought the firewall would block loopback connections, but just in case: are you sure it's disabled? Try running (as root): /etc/init.d/iptables stop

Also, are you sure the Tomcat process is still running? Check with: ps aux | grep java

share|improve this answer

If you have sufficient privs, try

netstat -an | grep LIST

and see if there is actually anything listening on port 8888. If so, try "127.0.0.1:8888" in your browser where you are now trying "localhost".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.