Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows 2008 VM that runs on an ESXi 3.5 server. It has two VMDKs attached to it: the boot drive and a 1TB data drive. The boot drive VMDK resides on some DAS drives on the server. The data drive sits on an iSCSI datastore.

We have been trying to migrate the VM to an ESXi 4.0 server. To save time we only converted the boot drive to the new ESXi server with the idea that we could attach the 1TB data vmdk later to the VM. The VM boots without the data vmdk attached. However, when we try booting the new VM with the data vmdk attached it POSTs but won't boot. The console shows a black screen; no Windows loading bar.

Does anyone have an idea why the VM would boot without the vmdk attached but won't boot with it attached? I really don't want to convert the VM again with the boot and data drive since it will take 7 days to complete.

share|improve this question
    
What happens if you try mounting the v3.5 vmdk onto the v4 VM AFTER it's booted? –  Chopper3 Nov 22 '09 at 12:29
    
Also can you mount that VMDK successfully to a Test W2K8 VM on the ESXi 4.0 server? –  Helvick Nov 22 '09 at 12:52
    
Chopper3, when I tried that the drive appeared in Device Manager. The OS wouldn't see any volumes on it though and it wouldn't show up in Disk Management. Helvick: I tried mounting it on another W2K8 VM and it wouldn't boot with it mounted either. –  zippy Nov 22 '09 at 19:51
add comment

1 Answer 1

up vote 0 down vote accepted

We ended up copying over the data manually on a new 1.2TB VMDK on the new VM.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.