Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I try to play sound from my monitoring application, which is an xp virtual machine on VMware ESX 3, on a physical machine with a real sound card, but I can not add from the ESX console sound card.

Currently, I transmit sound with opening an RDP session and play it in this session.

I would like to play sound without openning RDP session, do you have a solution to add a virtual sound card and then stream it with vlc?

share|improve this question

4 Answers 4

There is no way to support audio (or USB) inside of ESX and maintain portability/HA/vMotion according to VMWare. Sound is, as you already know, supported through RDP though. This works because audio is redirected to your machine which initiated the RDP session.

share|improve this answer
    
Is there any way to emulate a sound card like the rdp session without a rdp session ? –  AdrienF Nov 23 '09 at 18:25
1  
The sound card is not emulated in an RDP session, the audio is piped and processed on your own machine. If you need an application on a VMWare ESX(i) server to use a local sound card, you are out of luck unfortunately. –  MDMarra Nov 24 '09 at 2:01
    
Thanks, after knowing this, I stopped trying to add an audio device in Windows Server 2008 R2 and modified the local computer policy instead to allow audio and video redirection. This article also helped: kb.vmware.com/selfservice/microsites/… –  Jason Ilicic Jul 9 at 1:33

I finally found this, http://www.e2esoft.cn/vsc/, it solves my problem but it's a shareware and i really want an open source solution. If anyone knows an equivalent. Thanks for your answers.

share|improve this answer

check out spice-space.org currently this works in Red Hat's RHEV, not in ESX though.

share|improve this answer

Enabling sound for Remote Desktop Protocol in a Windows virtual machine (1004839) Purpose This article provides steps for enabling sound for Remote Desktop Protocol (RDP) in a Windows virtual machine. Resolution To enable sound in a virtual machine when connected using RDP:

Windows 2003:

Click Start > Run, type services.msc, and click OK.
Change the Windows Audio service to Automatic and start the service.
Click Start > Settings > Control Panel > Administrative Tools.
Click the Terminal Services Configuration section.
Double-click RDP-TCP.
Click the Client Settings tab.
Deselect Audio Mapping.

Windows XP and 2008:

Click Start > Run, type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Administrative Templates.
Expand Windows Components.
Expand Terminal Services.
In Client/Server data redirection, enable Allow Audio Redirection.
Restart the virtual machine.

Windows 7 and 2008 R2:

Click Start > Run, type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Administrative Templates.
Expand Windows Components.
Expand Remote Desktop Services.
Expand Remote Desktop Session Host.
In Device and Resource redirection, enable Allow Audio and Video Playback Redirection.
Restart the virtual machine.

Windows 2012:

Right-click Start and click Run.
Type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Policies.
Expand Administrative Templates.
Expand Windows Components.
Expand Remote Desktop Services.
In Device and Resource redirection, enable Allow Audio and Video Playback Redirection.
Restart the virtual machine.

Windows 2012 R2:

Right-click Start and click Run.
Type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Policies.
Expand Administrative Templates.
Expand Windows Components.
Expand Remote Desktop Services.
Expand Remote Desktop Session Host.
In Device and Resource redirection, enable Allow Audio and Video Playback Redirection.
Restart the virtual machine.

Notes:

Verify on the guest OS > Options > Local Resources.

Settings under Remote audio settings, the option Play on this computer should be enabled.

Windows XP may require the policy to be set to Enable.
Windows 2008 may require the policy to be set in User Configuration\Administrative Templates\Windows Components\Terminal Services.
Windows 2008 R2 requires Windows Audio Service to be started automatically.

To ensure that this service starts automatically:
    Click Start > Run, type services.msc and click OK.
    Change the service to start in Automatic mode.

Additional Information For more information, see the Microsoft Knowledge Base articles 818465 and 886199.

share|improve this answer
2  
The OP indicates that RDP is being used with sound and the OP wants to NOT use RDP but VLC or similar. –  Dave M Jul 14 at 22:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.