Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When running a database query on a specific external site we use, Squid seems to cut off the connection after a consistent period of time (just over a minute).

The query is submitted through a standard web form is that uses GET to query their database.

Firefox 3 just displays a blank page. Internet Explorer throws a 'Page Cannot Be Displayed' error (tested in v6 and v8).

When we perform the same query on the same machine, but bypass the Squid proxy, it works fine. The query takes about two and a half minutes to complete.

There are a few timeout settings in Squid, but I honestly don't know what one to be looking at.

Any possible solutions would be much appreciated.


share|improve this question

migrated from Nov 22 '09 at 22:45

This question came from our site for professional and enthusiast programmers.

I found no obvious defaults that would cause this behavior. Are you overriding any timeout defaults in your configuration? Have you looked at timeout settings in Squid Configuration Manual? – intgr Nov 18 '09 at 23:57

Second, check if the Website uses SPDY. Squid is not capable of SPDY right now, but both Browsers are. I have seen strange side effects on SPDY-Sites with Squid, like broken connections (after few minutes), pages that load only on the second refresh hit and sites that only loaded 70% of the content. Try to disable SPDY in the pptions (of the browser(s)).

share|improve this answer

Do you have connect_timeout defined in your squid.conf file? If not, you can set it higher than the default 1 minute.

connect_timeout 5 minutes
share|improve this answer

You could change the value of "request_timeout". This value does the following:

"How long to wait for complete HTTP request headers after initial connection establishment."

Just set the value like this: request_timeout 5 minutes

Hope that helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.