Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there anything special to setting up ubuntu 9.10 to use a proxy server besides going to Preferences->Network Proxy? I setup the proxy name in a similar way (proxy 8080), but also provide the authentication credentials in the pop-up box.

This is a proxy at work, which I believe to be a Windows machine (most likely some version of Windows Server). The computer I'm running is a laptop (with ubuntu 9.10).

I can't get ssh or Dropbox to work, but if I launch Chromium or Firefox and browse to a page, I'm prompted to enter credentials (my work computer login/pass, which are the same used on the proxy), and this works fine to browse any webpage. However, I still can't use ssh and Dropbox doesn't connect.

Further, Chromium has this option to infer the proxy settings from the operating system, but this appears to have no effect and I'm still prompted for credentials to get any page to come up.

I also tried setting up ProxyCommand in my ssh/.config, but apparently the man page is out of date as the options in the nc -X command -x proxy:8080 %h %p command aren't recognized. I tried this instead:

ProxyCommand nc proxy 8080 %h %p

But that doesn't work either. Any other things I should try or check out to try and debug the problem? Like I said, the credentials input through the browser are valid and get me access to webpages - I just don't know where else to try them out.

Update: Added sample screenshots of the Firefox/Chromium dialogs and prompts, which are both similar. As mentioned in the comment below, the credentials are added to the Details... dialog/pop-up in ubuntu's Preferences->Network Proxy dialog.

Update 2: So, proxytunnel 1.9.0 didn't build on the machine (an openssl directory missing from the proxytunnel source code, gcc barks). I did however get corkscrew built and installed, and added

ProxyCommand corkscrew proxy 8080 %h %p ~/.ssh/proxyauth

to .ssh/config, as shown here. Still no dice - I get an error:

Proxy Error (The specified Secure Sockets Layer (SSL) port is not allowed. 
ISA Server is not configured to allow SSL requests from this port. 
Most Web browsers use port 443 for SSL requests.)

and it's starting to look more like this other question off SO.

Update 3: I got the bright idea to try and use my work computer (Vista+Cygwin) and not the work server as my proxy, because I am able to freely ssh from the work computer (I'm guessing because of the MS Firewall Client). I found this ssl/ssh multiplexer utility which seems promising, but then I had the pleasure of trying to compile it under cygwin (it's not working).

So, is it possible to that? Could I set up something (a service, open a port, etc.) on my work computer to forward ssh/Dropbox traffic from the laptop correctly?

share|improve this question
can you add a snapshot of the prompt for credentials? I have my suspicions but I can't answer it until I "see" it. – Avery Payne Nov 23 '09 at 20:37
See links above - the dialogs are similar (they don't ask for domain - just username/password). – emptyset Nov 23 '09 at 20:57

Since you need proxy authentication you may need to look at something like proxytunnel instead of just netcat to get SSH through the proxy.

share|improve this answer
I'm going to give this a shot, thanks! – emptyset Nov 23 '09 at 21:19
It didn't work, see above for detail. I'll give compilation another shot later when I have time to track down what's wrong. – emptyset Nov 24 '09 at 17:12

It sounds like you're seeing realm-based authentication that's backed by an AD tie-in, but who knows? You need to provide a bit more information, including a snapshot of the dialog, what information is prompted (just username and password, or username/domain/password), is the prompt per-session or consistent until you log out, etc.

Also, if you've just set up the proxy info but not the username/password, why would you expect it to work? If you look at the second picture in that link you posted, you'll notice a "details" button to the far-right. Click that button, and you'll be prompted to activate authentication with a checkbox; after clicking the checkbox, put in a username and password. See if that gets you farther.

Ah, so it seems you're really interested in tunneling TCP traffic over HTTP. There are several ways to accomplish this, although would it probably be easier to just ask the firewall admin for the access you need (hey, I need to get access to XYZ site via SSH, any chance you could open that up...)

share|improve this answer
I did set the authentication information in the Details... dialog. – emptyset Nov 23 '09 at 20:49
The prompt is per browser session - but really I'm less interested in getting browsing to work (it does) than I am to get ssh and other things like Dropbox working (to synch up some files). – emptyset Nov 23 '09 at 20:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.