Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two Server 2008 servers (both running as VMs in VMware). One is a Full Installation, and the other is a Server Core installation. I just installed Print Services on both of them. In Print Management on the Full server, I added the Server Core print server (so now two print servers are listed in Print Management). However, the icon for my Server Core print server has a red, down-pointing arrow (indicating that it is down, I suppose). And when I right-click it and click Add Printer, I get a message saying that access is denied.

Can someone tell me how to bring up or check on the status of the Server Core print server. Obviously, I'm somewhat of a noob with this stuff. Thanks in advance...

share|improve this question
add comment

2 Answers

2008 has firewall active by default, with inbound filtering. As a quick test, disable the firewall on the Core:

netsh advfirewall set currentprofile state off

It should now be working. Then you can activate again the firewall and allow the blocked traffic (RPC i guess).

2 ways:

  • Locally on the core, through command line
  • With the firewall MMC from the other server

First way:

netsh advfirewall firewall set rule group="Rules to enable" new enable=yes

Second way: On the core, allow remote management:

netsh advfirewall set currentprofile settings remotemanagement enable

Then, on the non core server, you must launch mmc, add the Windows Firewall with Advanced Security console, so you are prompt to specify a remote computer

share|improve this answer
add comment

You should check the Remote Server Management Service also. I've bunch of 2008 Servers that I manage throught my office laptop with this MMC Service, but to use it you've to activate it on the server first.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.