Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with the deployment of Windows 7 from a Microsoft Deployment Toolkit Server. The installation of the Operating System works just fine but when it continues with the application installation, then some Applications return an error. Most of them I have figured out what the Error means, but I have two applications in my list which give following strange error codes.

Application ActiveX Installer Service returned an unexpected return code: -2145498548

Litetouch deployment failed, Return Code = -2147023589 0x8007051B

Does someone know what these error codes mean?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Solved the ActiveX Problem.

ActiveX is already installed in Windows 7. It can be found in the services menu. This may be the cause for this error. I have fixed it by only changing the startup type through the command line in the applications menu in MDT 2010. Following command will do the Job

sc config AxInstSV start= auto

As for the errors that are shown, I have found out (searching the instruction manual from mdt 2010) that you can resolve the errorcodes with the command line. Example:

net helpmsg 1307

Will resolve in

This security ID may not be assigned as the owner of this object.

If the error is like in my example a hex number you have to pick the last 4 characters. In my case the hex number is

0x8007051B

The last 4 characters have to be converted to decimal numbers. This can be done with calculator in windows xp by changing the view options to scientific and clicking on hex. In my case the characters entered would be

051B

To convert this by clicking on Dez. The number will resolve to

1307

Which can be resolved to a text message with the tool mentioned above.

I hope I could help others with that resolution.

share|improve this answer

I haven't seen the first error before (and do not see a single reference on Bing or Google), but the second message potentially relates to permissions, with error 1307, “This security ID may not be assigned as the owner of this object.”

That typically means either the logged-on user isn’t an Administrator (or isn’t running elevated) or a restrictive security template (e.g. SSLF) or GPO has been applied. Do any of those apply?

Is there anything in the logs that may help narrow down the problem? There is a listing of the logs, their locations and functions here: http://social.technet.microsoft.com/forums/en-US/itprovistadeployment/thread/6279c8b5-f0a6-449e-805d-70b9d0b1a83f/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.