Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

AnyConnect works fine with Windows XP.

On Ubuntu Linux 9.10 32 bit, I downloaded anyconnect-linux-2.4.0202-k9.tar.gz, installed it, and tried to connect to the same ASA firewall. It failed with:

  >> state: Connecting
  >> notice: Establishing VPN session...
  >> error: AnyConnect package unavailable or corrupted. Contact your system administrator.
  >> notice: Connection attempt has failed.
  >> state: Disconnected
  >> state: Disconnected

Then I downloaded anyconnect-linux-2.4.0202-k9.pkg from and installed it on the ASA's flash:

foobar# show flash
--#--  --length--  -----date/time------  path
   75  8192        Nov 12 2009 05:02:58  log
  154  4181246     Dec 31 2002 16:08:18  securedesktop-asa-
  155  398305      Dec 31 2002 16:08:40  sslclient-win-
   79  8192        Oct 24 2009 13:15:24  crypto_archive
  157  13934592    Nov 12 2009 04:52:54  asa805-k8.bin
  158  11491880    Nov 12 2009 04:56:48  asdm-623.bin
  159  3191813     Nov 12 2009 06:41:18  anyconnect-win-2.4.0202-k9.pkg
  164  5199492     Nov 24 2009 13:58:12  anyconnect-linux-2.4.0202-k9.pkg

255426560 bytes total (216465408 bytes free)

Tried again with Linux - fails exactly the same way. The ASA log says:

Group <DfltGrpPolicy> User <foo> IP <X.Y.Z.K> WebVPN session terminated: User Requested.

I'm out of ideas. Any suggestion?

share|improve this question
up vote 1 down vote accepted

Nevermind, my mistake.

It's not enough to upload the package to the ASA flash, you have to actually declare it in the config as an AnyConnect image file, otherwise it won't work.

Configuring the Security Appliance to Download the AnyConnect Client

share|improve this answer
This link does not require log-in:… – codeape Jan 19 '10 at 22:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.